Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
Re: [SLE] library dependency?
  • From: zentara <zentara@xxxxxxxxxxx>
  • Date: Tue, 5 Nov 2002 06:21:12 -0500
  • Message-id: <20021105062112.2e642643.zentara@xxxxxxxxxxx>
On Mon, 04 Nov 2002 20:57:01 GMT
John Pettigrew <john@xxxxxxxxxxxxxxxx> wrote:

>jpilot complains (when I try to install the rpm) that
>it needs libcrypto.so.0. Now, this is part of openssl and is installed on my
>system. The relevant file is present in /usr/lib (as a link to
>libcrypto.so.0.9.6 (I think)), and it works perfectly if I force it. So, why
>is it complaining? The annoyance is that, every time I start the YaST
>install tool, it complains about this.
>
>Any tips?

Yeah, this happens with alot of apps.

Go into /usr/lib and make symlinks
@libcrypto.so
@libcrypto.so.0

pointing to libcrypto.so.0.9.6

The apps look for the simple name of the lib instead of the full name.


--
use Perl; #powerful programmable prestidigitation

< Previous Next >
References