Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
Re: [SLE] Suse 8.0: only the gateway can be reached over internal network
  • From: "Peter Gloor" <pgloor@xxxxxxx>
  • Date: Sat, 2 Nov 2002 16:06:24 +0100
  • Message-id: <001601c28281$6a9d9720$0b0ba8c0@xxxxxxxxxxx>
Pieter Hulshoff wrote on November 02, 2002 8:34 AM
>
> >Destination Gateway Genmask Iface
> >192.168.11.0 192.168.11.1 255.255.255.0 eth1
> >212.xx.yyy.192 0.0.0.0 255.255.255.240 eth0
> >0.0.0.0 212.xx.yyy.193 0.0.0.0 eth0
> >
> >Btw, if I change the gateway to 192.168.11.70 which is
> >an ISDN router in the network it works. However, it
> >worked before with the above configuration I dont want
> >to (ab)use the ISDN router.
> >
>
> So your gateway is 192.168.11.1 on one interface, the server
> is 192.168.11.? on that same network, the ISDN router is
> 192.168.11.70 on that network, and then there are some
> computers with 192.168.11.? on that network, all with the
> mask on 255.255.255.0?

You got it. The Linux Servers IP address is 192.168.11.201 and
the other computers ip addresses are something between
192.168.11.11 and 192.168.11.131 on that network. All have a
mask on 255.255.255.0.

As an example, this is what ipconfig on my PC reports:
C:\WINDOWS>ipconfig
Windows IP-Konfiguration
0 Ethernet Adapter :
IP-Adresse. . . . . . . . . : 192.168.11.11
Subnetmask . . . . . . . . : 255.255.255.0
Standard-Gateway . . . . . . : 192.168.11.1
C:\WINDOWS>

> Do you only have to change the gateway on the server to the
> ISDN router for the other computers to see this server, or
> do you have to change it on all computers in the network?
>

I only need to change the gateway on the Linux Server.


> My apologies for all the questions, but I'm trying to get a
> view of how your network is setup. This problem is slightly
> more complicated than I had hoped at first. :)
>

No problem.

In addition, on the same network, there is a MS Proxy server.
The goal is to replace this proxy with a Linux (squid) proxy
server.

There might be one other thing you need to know. Physically
the network is divided into two segments with two hubs. One
hub (not sure, it might be a switch) serves all PC's and
servers with 100 Mbit interfaces. The other one is a hub (for
sure) which serves some older PC's and servers with 10 Mbit
interfaces. There is also a coax attached to it which still
serves 2 or 3 servers. There is a link between the two hubs.

I'm telling this because first I used a 100 Mbit NIC, but I
connected this with the 10 Mbit hub. This is similar to the
gateway configuration which uses the same 100 Mbit NIC, but
is attached (as the only exception) to the 10 Mbit hub (due
to negotiation it automatically swites down to 10 Mbit). All
Other PC and server have either 100 Mbit NICs attached to the
other hub/switch or have 10 Mbit NICs attached to the same hub.

I tried to change the NIC's, but the problem still exists.

I expect the problem to be somewhere in the Linux config, but
I have no idea where to look at. I cannot imagine an entry in
the config that could cause this problem, like a kind of entry
for "Don't use/use old routing protocol".

The logs don't show any error or deny messages. Ping and
traceroute indicate that the other NETWORK cannot be reached.

I was a little bit surprised to find a completely new network
configuration introduced with SuSE Linux 8.0. I will go thru
the documentation to get familiar with it this weekend.

Peter


< Previous Next >