Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
Re: [SLE] 8.1 Updating the Base System by FTP
  • From: Maintaniner on duty <hugh@xxxxxxxxxxxxxxxxx>
  • Date: Sat, 2 Nov 2002 22:30:03 +0900 (KST)
  • Message-id: <Pine.LNX.4.33.0211022157040.6225-100000@xxxxxxxxxxxxxxxxx>


On Sat, 2 Nov 2002, Sean Haley wrote:

> >TJ wrote:
> >>Hi,
> >>
> >>I'm a bit puzzled over how updating the whole system should work. I
> >>installed 8.0 "clean", but have been using "update whole system" before
> >>that since 6.x successfully.
> >>
> >>I now have SuSE 8.1 boot.iso on CD, but when starting the
> >>"install/update" (from the manual installation program) and the
> >>graphical installation begins, it only offers an option of "new
> >>install" or "boot installed system". New install is what proposes
> >>formatting of the linux drives, and when trying to select "don't
> >>format" the installation program warns that I shouldn't be doing that
> >>if the root partition is already in reiserfs-format (which it is).
> >>
> >>I remembered that with YaST2 there's a new tool called "system update",
> >>so I figured out that probably I shouldn't be updating via boot cd
> >>anymore like in the old times. Still, the system update doesn't offer
> >>any 8.1 packages to install, even though I've used the "change source
> >>of installation" to point to the new SuSE 8.1 -ftp-directory. Instead,
> >>it proposes some 30 of minor updates and tries to fetch them from
> >>/var/adm..something and fails (???).
> >>
> >>Now would anyone have a clean, simple answer to what should I use to
> >>update my existing SuSE 8.0 installation to a 8.1 one via FTP?
> >
> >I have the same problem here with the same setup. I event tried to boot
> >from floppy disks just in case there was any problem with iso image,
> >still no luck.
> >
> >I'd appriate for any insight.
>
> I hate to say it but "mee too". Is there anyone out there that has had
> success doing a base system update from 8.0 (bought version) to 8.1 ftp
> version? I donloaded the boot floppies for 8.1 and when yast was loaded
> there was no option for "update existing system". So I put in my 8.0 and
> attempted to do an ftp install but the only network option is nfs! This
> is in contrast to what it was going from a bought version of 7.0 to 7.2
> ftp online version. Grrr!!! SuSE! I even tried to install from a
> "borrowed" 8.1 cd but it failed to start with a kernel panic! So I'm
> afraid to even buy 8.1!
>
> David
>
>
> I'm also a bit confused with the proceedure. I do the Automatic installs
> within the Linux environment. Then when I get ready to follow the
> instructions in the Admin guide for Manually Updating the Base System - it
> gives me questions I can't answer such as the IP address of the FTP server
> and (cannot mount file system) when potinting to my hard disk root.
>
> Any help appreciated.
>
> S
>

Your quoting confused me a little. Your problem can be solved.
You need to look up your current IP number (type "ifconfig"), your
DNS number (type "more /etc/resolv.conf"), your gateway number
(type 'more /etc/sysconfig/network/ifcfg-eth0') and your
FTP server name or number.

Our problem is even more serious. It appears that SuSE want all
of us to buy their package, if we want the "update" option.

>From a personal mail I received,
it appears that booting with the bought DVD to access the ftp
repository gave him a kernel panic.
About this occasion, I need a confirmation from someone else.


Thanks a lot.

Hugh



< Previous Next >
References