Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
Re: [SLE] Office Jet and CUPS
  • From: Tim Hanson <tjhanson@xxxxxxxxx>
  • Date: Sat, 02 Nov 2002 00:38:16 -0800
  • Message-id: <3DC38EF8.8030207@xxxxxxxxx>
All that worked. I've even got a script written which will keep the time on the
printer up to date. I have the kde app for reading the display on my desktop.

After fighting with it for SEVERAL more hours, I gave up, installed lprng,
hooked up the parallel port, and now I'm printing. I wonder if I can get it to
scan from the usb port while the printer port is attached. Don't see why not.

Kin Ho Cheung wrote:
> Have u look to see if the usb modules a loaded u need at least usbcore,
> usb-uhci (or uhci) and the printer modules. Also when u ran the
> ptal-init setup it did detect the printer on the usb port. Oh one more
> thing there is apparently a bug in cups 1.1.16 that won't allow the ptal
> to work properly in cups u need either cups 1.1.15 or the CVS of the
> upcoming 1.1.17.
> Tim Hanson wrote:
>
>> That's what I thought, but when it gets to the devices, the ptal
>> device isn't on the list. I even tried manually stopping cups,
>> restarting ptal-init, then starting cups, all from the command line,
>> but still no listing. It shows a JetDirect, an Apple, a couple of lpr
>> / lpd choices, then all the parallel printers, all the usb printers,
>> and finally a couple of Samba/Windows drivers. I found a configuration
>> file in /etc/cups, but I don't know what to put there.
>>
>> Kin Ho Cheung wrote:
>>
>>> I'm not running 8.1 so I'm not exactly sure but once u have confirmed
>>> that ptal and cups is up and running, u need to set the printer
>>> protocol to use the ptal not usb. just goto
>>> http://localhost:631/printers and click on the modify printer button
>>> then click continue until u get to device page and from the list of
>>> device select ptal. Also u must have runned "ptal-init setup" i
>>> think before ptal will show up as a device. Tim Hanson wrote:
>>>
>>>> I'm having a hard time getting my HP usb Office Jet to print under
>>>> CUPS. I'm running 8.1 Prof.
>>>>
>>>> I'm using the HP docs found in /usr/share/doc/packages. I get to
>>>> the point where I can talk to the set the time, etc. I put lines in
>>>> my /etc/init.d/cups script to load /usr/sbin/ptal-init before CUPS.
>>>> At this point I should see the spooler, /usr/sbin/ptal-cups as one
>>>> of the printer options, or else give me another way to write to the
>>>> spooler. When I use usb1 as the destination, the job disappears,
>>>> which I already know about and expect.
>>>>
>>>> Does anyone know how to make this work?
>>>
>>>
>>>
>>>
>>>
>>>
>>
>>
>
>


--
Think big. Pollute the Mississippi.




< Previous Next >
Follow Ups