Mailinglist Archive: opensuse (3378 mails)

< Previous Next >
Re: [SLE] can't mount CD with SuSE 8.0 [SOLVED]
  • From: neal mcdermott <neamcd@xxxxxxxxxx>
  • Date: Fri, 26 Apr 2002 08:13:43 -0700
  • Message-id: <200204260811.35231.neamcd@xxxxxxxxxx>
On Friday 26 April 2002 03:14, Keith Winston wrote:
> On Fri, Apr 26, 2002 at 01:37:52AM +0200, Anders Johansson wrote:
> > > Oh, one last question. When an issue is solved like this, can I just
> > > append the word solved to the subject line, or is that starting a new
> > > thread?
> >
> > No, that's what appears to be the trend so that's what you should do.
> >
> > Anders
>
> As Anders said, it is good netiquette to post the final resolution with
> the subject and a [SOLVED] either at the beginning or end. Helps people
> searching the archives for solutions :)
>
> Best Regards,
> Keith

Okay, so this was the problem:

Just installed 8.0. on a Dell Inspiron 3500 laptop, and it has recognized my
IDE CDRW, which is good, since 7.3 was unable to, but when I click on the CD
icon on the KDE desktop, I get the error message:


Could not mount device.
The reported error was:
/dev/cdrom: Input/output error

mount: I could not determine the filesystem
and none was specified.



One difference from the 7.3 install is, this time, instead of only one icon
appearing on the KDE, there are two icons appearing on the Desktop for the
same drive. In addition to the aforementioned CD ROM icon, there is also an
icon labelled: CD-R. When I click on this one, I get the same message,
only instead of reporting the error as /dev/cdrom: input/output, it reports
it as /dev/cdrecorder: Input/output.


And this was the response from Keith Winston.

SuSE 8.0 set up the link incorrectly since you have an IDE CD-RW. The
> link should be to /dev/sr0. You can fix it, as root, with:
>
> rm /dev/cdrom
> ln -s /dev/sr0 /dev/cdrom
>
> I just had to do the same with mine. Also, if you want to burn CDs as a
> user instead of root, go ahead and make it world writable...
>
> chmod a+rw /dev/sr0
>
> And, if you want to rip CDs using grip, do this too...
>
> chmod a+rw /dev/sg0
>

So that fixed the problem, but didn't know it yet because I still could not
click on the CD icons on the desktop and see the contents of the disk.

The next response came from Anders Johansson who asked what sort of disk I was
trying to open. It turned out to be a music disk, which he informed me
cannot be mounted because it has no filesystem. So I tried other CDs, both
the setup CDs from SuSE and data CDRs and CDRWs that I had made myself, and
they all worked.

Thanks again to all who responded.

Neal




< Previous Next >