Mailinglist Archive: opensuse (3378 mails)

< Previous Next >
Re: [SLE] KDE3 rpm's moved
  • From: Tim van Venrooij <venrooij@xxxxxxxxxx>
  • Date: Sun, 14 Apr 2002 12:39:49 +0200
  • Message-id: <20020414123949.A2799@xxxxxxxxxxxxxx>
Hi,

FYI, when you install the SuSE KDE3 packages, the KDE2 packages kdebase
and kdelibs are removed. That's the reason why kdm does not work any
longer. Also the startkde script seems somewhat screwed up: it uses
variables KDEHOME and kdehome, the latter uninitialized. Furthermore, it
does not refer to ~/.kde3 by default as stated in the comment but to ~/.kde
instead. It does not start via a login shell either. Another thing is
that the latest SuSE KDE3 rpms do not contain any descriptions.

To my opinion, this sort of issues should have long been resolved before
moving the KDE3 packages from the experimental to the normal directories.
Considering that at the same time the stable KDE2 core packages
were removed from these directories... Bad move SuSE, shame on you.

OK, in the end I got it working, KDE2 and KDE3 together, but it took
quite some tweaking and patching.

Regards,
Tim

On Sat, Apr 13, 2002 at 07:02:19PM -0700, Ben Rosenberg wrote:
>
> ... Leave KDE2.x.x installed on your system and just
> install kde3 in the directory it's suppose to go which is /opt/kde3. And
> it will not interfere with KDE2.x.x .. you can even run KDE2 apps such
> as the ones I run (ex. Licq and Kinkatta)
>
> You have to go into /etc/rc.config and change the references from kde2
> to kde3 and if you specified the directories for KDE and QT in your
> .bashrc (the file that sets environment variables after login for your
> shell) then you have to change it from kde2 to kde3. It's pretty much
> that simple. I installed the KDE3 rpms from kde.org (which were made by
> a SuSE employee) and haven't had much of an issue. I tried the ones on
> SuSE's ftp site on my workstation in the office..this was a big
> mistake..I had to revert to the kde.org builds.
>
> If you have KDE and QT specified in your .bashrc or globally in
> /etc/profile make sure it looks like this...
>
> --
>
> KDEDIR=/opt/kde3/
> QTDIR=/usr/lib/qt3
> export KDEDIR QTDIR
>
> --
>
> If it says kde2 then you will get all sorts of weird shit happening when
> you try to load kde3 because the wrong places for KDE and QT are set as
> environment variables.

< Previous Next >
Follow Ups