Mailinglist Archive: opensuse (3378 mails)

< Previous Next >
Can't stat file, no more X. (hacked?) long
  • From: d herman <ob1@xxxxxxxxx>
  • Date: Sat, 13 Apr 2002 11:08:17 -0700
  • Message-id: <20020413180307.95418E65AC@xxxxxxxxxxxx>

This is my horrible situation
suse 7.2 professional, xfree86 4.2, kde2.2.2
Konqueror, java, javascript, cookies enabled

I've been to a few portscan sites, grc, securityspace, etc and their reports have shown my system to be reasonably
secure (stealth).

I was reading e-mail and surfing the web this morning, hadn't really been to to many sites (mcaffee.com,trying to get stuff
to clean up my wifes winders partition). I'd seen a few popups from mcaffee but closed them before they loaded as that
is my choice of how to deal w/ popups.

As I read my e-mail I switched from one workspace to another and Konq sent up a crash message. I wasnt to worried
about it and just closed the window expecting konq to quit.

My hard drive went into continuous activity, screen didn't really go black, just mostly black. The only real way I can
describe it is that It looked like something I was used to seeing when my Amiga would to crash. It was obvious that my
X session was over!

I did a hard reset even though the drive was running (knowing I would have to wait for error checking).

When the system came back up there was no X

I saw messages related to can't stat /tmp/...
Renamed /tmp and created a new /tmp
rebooted
Still no X
init 1
Tried re-installing X w/ yast
ran sax 2 and saved, no errors reported
init 5
still no x

Decided to investigate /etc/X11
got a message "can't stat XF86Config"
when I ls -la it shows everything but XF86Config
mc will let me into the directory but not show /etc/X11/XF86Config

I came to the conclusion that the ownership of the file had changed.
Ive tried chown, chmod etc but nothing will let me alter this file.
I'd like to see the fite attributes and find out if ownership had changed but I can't examine the file in any way.
I thought I was supposed to be able to do anything as root.

I used yast and didn't find any unusual users or groups.

Help! I've got no more Ideas

Thanks

dave






< Previous Next >
This Thread
  • No further messages