Mailinglist Archive: opensuse (3378 mails)

< Previous Next >
Re: [SLE] How to make CUPS work for Canon PS (not in supported list)
Thanks for your help, so far. It's appreciated.

Here's what's happening, so far.

Yes, I also used http://localhost:631/ to configure.
However...

I provided the URI lpd://canon/PRINT

where - "lpd" seemed as good as anything else...
- "canon" was defined in /etc/hosts as
172.16.11.20
- "PRINT" is what many Canons seem to call
themselves, in private (otherwise PRINTR4)

BUT... then the Admin web wizard went to the next
page of the configuration and demanded that I pick
a "model" from the provided list (same requirement
if I try to config via YaST2).
As mentioned in earlier messages, I find that the
provided list does NOT contain my printers (nor
any in their series, if I'm reading correctly... I
may not be... wouldn't be the first time... :-)
I see mostly outdated small models, not the big
departmental beasts that are found in modern companies.

So anyway, the Admin interface will not let me
skip that step. I absolutely MUST choose a printer
model. I pointed to one, just to make it stop
pestering me, and finished the config by sending
a test page.

The good news is that the printer printed.

The bad news is that it printed 100 pages
of gibberish before I could get the job
stopped. It did not even appear to be
printing postscript codes, just junk characters
and overprinting.

I tried again, choosing another Canon model,
but the same thing happened.

I tried choosing "Raw", instead of a printer
model, but the config kept dumping me back
in the "Choose a printer model" list, until
I relented and picked another model. This is
not working, but at least I now get to waste
a lot of paper. The company loves it when
I do that. :-)

The actual physical printers are, indeed,
PostScript models, so it appears that the
postscript processor is not being addressed.
I'm stuck again, wondering what's wrong
and what to do next. At least the printer
device is being addressed.

Again, I do have that PPD file from the Canon CD,
but I don't see how to make that file accessible
to the CUPS Admin. Anybody have a suggestion?
Is there a config file where I should mention
the name of the .ppd file??

Thank you for your patience.

/kevin (aimlessly killing trees in Ottawa)


On Fri, 2002-04-12 at 13:08, Alexandr Malusek wrote:
> Kevin McLauchlan <kmclauchlan@xxxxxxxxxxxxxxxxx> writes:
>
> > So, what do I put in a URI?
>
> I use:
>
> DeviceURI lpd://canon/print
>
> where "lpd" is the protocol name, canon is defined in /etc/hosts, and
> "print" is the queue name which is listed in the printer's
> documentation.
>
> > I have a PPD file that comes from the Canon CD
>
> I just selected a similar PS printer and didn't play with ppd files.
> It worked in my case.
>
> I used http://localhost:631/ to configure CUPS.




< Previous Next >
Follow Ups