Mailinglist Archive: opensuse (3644 mails)

< Previous Next >
Sound
Hello, all.

DISCLAIMER:
I read the Linux Sound HowTo, and it did not
appear to mention my particular problem.

I searched the archives back to October and
did not find this particular problem (and it
took a couple of hours for that search...).
/DISCLAIMER

I haven't tried to play anything for a long time,
but today I tried to play a music CD, and sound
is broken.

I get this message:

**********************************************
"Error accessing CDROM device.
Please check to make sure cdrom drive support
is compiled into the kernel, and that you have
permission to access the device.

Reason: Permission denied."

**********************************************

Now, this strikes me as just a bit misleading
(not to say malicious), because:

1) I certainly do have permissions, because I
logged in as root and tried it, with the same
response, and last I heard, root has every
permission in the universe.

2) I just re-configured sound, and the problem
is unchanged, even though, during the config
(with YaST2) I was able to play the test tune
and to adjust the volume.

3) I just mounted and read a CDROM from that drive,
so I suspect that I probably do have CDROM support
(though why that should matter for audio CDs, I
don't know...).

In addition, I checked bootlog.msg, and it confirms
that alsasound started (returned 0... which is what
it's supposed to return if it starts successfully,
isn't it?)

I looked at /dev, and there are several audio devices
(audio, audio0, audio1, etc.) all with permissions
and ownership listed as:

crw-rw-rw- 1 root audio 14, 4 Sep 23 21:54

What-in-heck-else am I supposed to do?

SuSE 7.3 with Ximian-GNOME on a DELL Latitude C600.

Oh, keep in mind that anything I did, above, I
did because the word "sound" was vaguely connected
to it, not because I knew what I was doing. I don't.

Thanks for any help.

--
Kevin McLauchlan
Chrysalis-ITS, Inc.
"Ultimate Trust(TM)"


< Previous Next >
Follow Ups