Mailinglist Archive: opensuse (3644 mails)

< Previous Next >
Re: [SLE] Apache installation in SuSE 7.3 hosed?
  • From: <dog@xxxxxxxxx>
  • Date: Mon, 4 Mar 2002 08:01:13 -0600 (CST)
  • Message-id: <Pine.LNX.4.33.0203040759570.32552-100000@xxxxxxxxxxxxxxx>
so is apache working for you now? the only problems I have ever had with
suse's apache packages are not installing all the dependency rpms
(especially with mod_php which requires a lot of other rpms be installed)

You said:

NOTE: This is for reference only, so somebody
who has the same problem may safe some time
when apporaching SuSE's installation support
and is told that this is beyond the scope
of installation support and $$.... (happened to me
in other cases, one where their ftp server had
an alpha binary in the i386 section)

The Apache server is not working on my machine.
I did a delete with Yast and a reinstall.

The behavior changed somewhat but is not coming up.

SuSE support database comes up with one possible
match: http://sdb.suse.de/en/sdb/html/rschmid_71apache.html
but this is for PPC - I am i386 and the steps mentioned
are irrelevant due to different file contents (httpd.conf)
or don't work - symbolically linking.

a text search on relevant text strings (libssl.so, error
messages) in the mailing list posts of this list since
11/21/2001 failed to bring up anything relevant.

hint:
http://www.mail-archive.com/modssl-users@xxxxxxxxxx/msg10477.html.
but requires recompile of Apache which goes beyond what I
want to do right now.

Solution: install mod_ssl and open_ssl from the sec1 and sec2
subdirectories made it work(I am not sure if the open_ssl
was necessary). Apparently, there is some dependency missing

Below are the messages I encountered.

# apachectl start
Syntax error on line 1 of /etc/httpd/suse_loadmodule.conf:
Cannot load /usr/lib/apache/libssl.so into server:
/usr/lib/apache/libssl.so: cannot open shared object file: No such file or
directory

linking from /usr/lib did not work:

ln -s /usr/lib/libssl.so.0 /usr/lib/apache/libssl.so

and gives:

# apachectl start
Syntax error on line 1 of /etc/httpd/suse_loadmodule.conf:
Can't locate API module structure `ssl_module' in file
/usr/lib/apache/libssl.so: /usr/sbin/httpd: undefined symbol: ssl_module
/usr/sbin/apachectl start: httpd could not be started

deleting lines in /etc/httpd/suse_loadmodule.conf did not work and gives:

# apachectl start
Syntax error on line 1 of /etc/httpd/suse_addmodule.conf:
Cannot add module via name 'mod_ssl.c': not in list of loaded modules


Samartha


--
To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the FAQ at http://www.suse.com/support/faq and the
archives at http://lists.suse.com


Chad Whitten
Network/Systems Administrator
neXband Communications
cwhitten@xxxxxxxxxxx


< Previous Next >
References