Mailinglist Archive: opensuse (4053 mails)

< Previous Next >
Re: [SLE] Which CD is the Live CD?
I found several support articles which discuss this on the Suse site. I do not know if you have tried them, but here they are:

(thanks SuSE for your wonderful support structures and mailing lists)

Symptom: (this looks as if it is most likely to help you)

You would like to install SuSE Linux on your system or update your current system and receive the
error message

The module inst_rpmcopy does not work

During the update process the SCSI system may display a

timeout

or a different message.

Cause:

Kernel 2.4.4 contains a new SCSI module for Adaptec controllers. The above mentioned error
occurs when using some older models of Adaptec controllers.

Solution:

New Installation

Please check if there is an entry in your BIOS settings like "Plug & Play Operating System"
(often reduced to "PnP OS"). Make sure that the value for this setting is switched to "no",
"disabled" or equivalent. Reboot your PC from CD 1 (or bootdisk / DVD) which came with
SuSE Linux 7.2 and select "Manual" from the boot menu. Please beware that you will have to type
in

manual

at the boot prompt ("boot:") if you decide to boot your PC from the bootdisk.

After the selection of colour, language and keyboard layout please select the item "Kernel
modules (hardware drivers)" and then the SCSI module 'aic7xxx_old'. Resume with the
installation process according to the book SuSE Linux 7.2 The Reference chapter 2.1.

Update

When updating the problem is an obsolete entry in the file /etc/rc.config. To edit this file
please follow these instructions:

Put in either CD 1, the DVD or the bootdisk which came with SuSE Linux 7.2 and switch
the boot sequence in your BIOS settings accordingly if necessary.

Please make sure that a setting in the BIOS named "Plug & Play Operating System" (often
reduced to "PnP OS") is switched to "no", "disabled" or equivalent if applicable.

Select "Manual installation" from the boot menu. If you boot from the bootdisk please enter
the parameter

manual

at the boot prompt ("boot:").

After selecting the setting for colour, language and keyboard layout please select the item
"Kernel module (hardware drivers)" from the main menu and then the SCSI module
'aic7xxx_old'. Proceed by selecting the item "Start installation/boot system" and then
"Boot installed system". You will be asked to enter your root partition to boot your SuSE
Linux system.

Please login as user 'root'

Edit the file '/etc/rc.config' with your favourite editor.

Please do not use KEdit, because this editor automatically adds carriage returns. If
you want to use this editor, please make sure that this feature is disabled.

Search the following entry in the file:

INITRD_MODULES="aic7xxx aic7xxx_old"

This entry has to be substituted by:

INITRD_MODULES="aic7xxx_old"

Please beware that additional entries in the appropriate row must not be altered,
exchanged with each other or deleted. Otherwise the system may lack additional modules
when booting.

Finally save the file and quit the editor.

Please run the following command to let the system make use of the altered configuration
file:

mk_initrd

LILO has to be re-installed by typing in the command:

lilo

When the system is booted again the kernel module 'aic7xxx_old' will be loaded and the boot
process should be carried out successfully.

Symptom:

After the start of Linux via LILO the machine hangs during the initialization of the harddrive (ID0).
However it is possible to start Linux via the bootdisk (that was delivered with the distribution)
without any problems.

Cause:

The BIOS settings of the controller are not yet configured correctly.

Solution:

If you have an Adaptec controllers of the type 2940 and a BIOS version 1.23, it helps to switch
off Sync-Negotiating in the BIOS of the controller

Symptom:

You are using an adaptec SCSI controller like models 2940U or 2940UW and have connected some devices to it. Unfortunately not all
devices were detected during Linux-side initialization of the controller. The computer stops with an error message like this one:

Freeing unused kernel memory: 64k freed
SCSI disk error: host 0 channel 0 id 1 lun 0 return code=1
scsidisk I/O error: dev 08:01, sector 147978
SCSI 0: channel 0 target 1 lun 0 request sense failed, performing reset.
SCSI bus is being reset for host 0 channel 0.
SCSI disk error: host 0 channel 0 id 1 lun 0 return code=1
scsidisk I/O error: dev 08:01, sector 81932
EXT2-fs error (device sd(8,1)): ext2_read_inode: unable to read inode block - inode=10201, block=40966
(scsi0:0:1:0) Synchronous at 40.0 Mbyte/sec, offset 8.
(scsi0:0:1:0) Performing Domain validation
(scsi0:0:1:0) Successfully completed Domain validation
Kernel panic: No init found. Try passing init= option to kernel.
SCSI disk error: host 0 channel 0 id 1 lun 0 return code=1
scsidisk I/O error: dev 08:01, sector 152532

Cause:

The selection timeout of the modul aic7xxx defaults to 64ms. Nevertheless, some devices, especially older ones, need more time, for
instance the ANSI SCSI-1 standard conforming 256ms.

Solution:

Use the option seltime on loading of the module aic7xxx:

aic7xxx=seltime:0

This options sets the controller to selction timeout of 256ms.


In the README file for the aic7xxx module are the following parameters for seltime defined:

0 - 256ms
1 - 128ms
2 - 64ms
3 - 32ms

Symptom: (hopefully this is not it, this looks like the ugliest solution)

You have a SCSI controller of brand Adaptec AHA-19160, AHA-29160 or AHA-39160 and cannot install your copy of SuSE Linux.
Durning load of the corresponding module aic7xxx it seems the computer locks up.
On Terminal 4 messages like the following are continually displayed:

scsi 1 host
scsi : aborting command due to timeout: pid 0, scsi0, channel 0, id 0, lun 0 Test unig re00 00 00 00 00
scsi : aborting command due to timeout: pid 0, scsi0, channel 0, id 0, lun 0 Test unig re00 00 00 00 00

Cause:

These SCSI controllers require the use of an unique interrupt caused by the design of the driver. They cannot share interrupts with other
PCI cards.

Solution:

The only possible solution is the reconfiguration of the assignment of interrupts in the BIOS of your computer. Please have a look in the
manual of your mainbaord.
It may also be possible, that you have to change the PCI slot of your SCSI controller card.

Usually there is a table displayed during boot, where your can check the assignment of interrupts to PCI devices. Here you may have a
look, if your configurations succeeded

08/29/01 09:55:23 AM, Ron Cordell <roncordell@xxxxxxxxxxxxxxxx> wrote:

>I did that, but it still can't find it. What specifies the path to aic7xxx?
>It appears that the kernel is looking in a different place than the
>2.4.4-4GB/drivers tree.
>
>-ronc
>
>On Wednesday 29 August 2001 10:50 am, Harrell, Tim wrote:
>> add aic7xxx to INITRD_MODULES in /etc/rc.config.
>> Run SuSEconfig and mk_initrd (and lilo) just to make sure.
>>
>> If that doesn't work when you reboot, try the old one instead.
>>
>>
>> Tim Harrell
>>
>> -----Original Message-----
>> From: Ron Cordell [mailto:roncordell@xxxxxxxxxxxxxxxx]
>> Sent: Wednesday, August 29, 2001 3:42 PM
>> To: 'SuseLinux'
>> Subject: Re: [SLE] Which CD is the Live CD?
>>
>>
>> The problem isn't as grave as I thought. Since this machine used an
>> Adaptec
>> SCSI adapter card, the issue is that when the kernel boots, it is
>> attempting
>> to load the module "aic7xxx" and can't find it. I looked in the
>> /lib/modules/linux-2.4.4-4GB/drivers/scsi directory and see that there
>> is an
>> aic7xxx driver there, one called aic7xxx_old, and another called
>> aic7xxx/aic7xxx. So, where do one of these need to be placed so that
>> kernel
>> finds it when loading?
>>
>> -ronc
>>
>> On Wednesday 29 August 2001 10:29 am, Harrell, Tim wrote:
>> > you should be able to mount the partition of interest
>> >
>> > eg, assuming root partition was on /dev/hda..
>> >
>> > mount /dev/hda /mnt (assuming default ext2 fs)
>> >
>> > cd /mnt
>> >
>> > root filesystem as was should be there
>> >
>> >
>> > Tim Harrell
>> >
>> > -----Original Message-----
>> > From: Ron Cordell [mailto:roncordell@xxxxxxxxxxxxxxxx]
>> > Sent: Wednesday, August 29, 2001 2:52 PM
>> > To: suse-linux-e@xxxxxxxx
>> > Subject: Re: [SLE] Which CD is the Live CD?
>> >
>> >
>> > OK, I've got the rescue system going. From there I should be able to
>> > move the
>> > files of interest on the main drive elsewhere and then re-install
>>
>> SuSE.
>>
>> > I
>> > can't seem to determine how to mount the filesystems of the old system
>> > and
>> > undo what I did. Any ideas here?
>> >
>> > -ronc
>> >
>> > On Wednesday 29 August 2001 09:23 am, Ron Cordell wrote:
>> > > I did a stupid thing and updated the kernel image on my fileserver
>> >
>> > without
>> >
>> > > thinking, from 2.4.0-4GB to 2.4.4-4GB. While this worked fine on two
>> >
>> > other
>> >
>> > > machines, I installed the wrong image on the fileserver, and now of
>> >
>> > course,
>> >
>> > > it won't boot, getting "Kernel Panic" messages.
>> > >
>> > > I think that the default kernel image on the SuSE 7.1 update/kernel
>> >
>> > ftp
>> >
>> > > directory is for i686 machines, while I needed to use the i386 image
>> >
>> > on
>> >
>> > > this machine - it is a Pentium 266.
>> > >
>> > > In any case, I can't seem to determine which CD out of the 7 is the
>> >
>> > Live
>> >
>> > > CD. I need to boot into Linux, mount the root file system, and
>>
>> install
>>
>> > the
>> >
>> > > correct kernel. Which CD is it?
>> > >
>> > > Any other advice and name calling is welcome.
>> > >
>> > > -ronc
>
>--
>To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
>For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
>Also check the FAQ at http://www.suse.com/support/faq and the
>archives at http://lists.suse.com
>
>




< Previous Next >