Mailinglist Archive: opensuse (4053 mails)

< Previous Next >
RE: [SLE] KDE 2-2 Dependency Hell
  • From: "Harrell, Tim" <HarrelT1@xxxxxxxxxxxxxxxx>
  • Date: Wed, 29 Aug 2001 14:50:26 +0100
  • Message-id: <FC3DA3DC8D4AD311AB910020352A8FDC0594A3A6@xxxxxxxxxxxxxxxxxxxxxx>
Ok chaps I tried this but if I run anything that starts up the Arts
soundserver (artsd) then my X system locks up and has to be killed from
a virtual console. I can reproduce this at will.

I guess this missing libmcop_mt.so.0 that kdelibs-artsd.2.2.4 requires
is an issue after all.
:-(

Tim Harrell

-----Original Message-----
From: Jaakko Tamminen [mailto:jtamminen@xxxxxxxxxxxxx]
Sent: Wednesday, August 29, 2001 2:29 PM
To: Fergus Wilde; SuSE list
Subject: Re: [SLE] KDE 2-2 Dependency Hell


Hi

I did the same.. dowloaded everything from SuSE, and then did

rpm -i --nodeps --force <package>

for every package, and it has been working ever since.

Jaska.


Viestissä Keskiviikko 29. Elokuuta 2001 13:30, Fergus Wilde kirjoitti:
> I had good luck by simply forcing the install using --nodeps and
> --force arguments to rpm. I used rpm -Fvh or -
> Uvh to upgrade all the packages,
> starting with libwhatever, qt, then kdelibs, kdebase, and the rest.
> Did you put on those funny little libogg, libvorbis, libdoodliesquat
> library collections found on the SuSE site? The dependencies all
> appear to sort themselves out once you've got all the packages on.
> Then ran SuSEconfig, and the job was done. What's more, I did the
> upgrading from within kde 2.1. It didn't seem to care.
>
> Why not give it a whizz?
> Best
> Fergus
>
>
> ----- Original Message -----
> From: "Harrell, Tim" <HarrelT1@xxxxxxxxxxxxxxxx>
> To: "'SuseLinux'" <suse-linux-e@xxxxxxxx>
> Sent: Wednesday, August 29, 2001 10:36 AM
> Subject: [SLE] KDE 2-2 Dependency Hell
>
> > I have tried to upgrade my KDE 2.1.2 system to KDE 2.2 using all
> > the base packages supplied on the SuSE KDE Update page.
> >
> > The problem is that the base packages don't seem to be
> > self-contained. ie they require capabilities which are not present
> > in the other (2.2) packages or installed on the existing system.
> >
> > An example is the kdelibs-artsd package which is one of the
>
> requirements
>
> > of the 2.2 kdebase (libarts, etc).
> > This package requires libmcop_mt.so.0.
> > However none of the other 2.2 packages provide this and it is not
> > on
>
> my
>
> > system so where am I supposed to find it?
> >
> > The same is true of cups which requires libcups.so.2
> >
> > There are lots more examples like this: I had to back out my last
> > (forced upgrade att
>
> empt) by removing and reinstalling KDE 2.1.2 back
>
> > onto the system.
> >
> > So what am I missing guys? (I'm running 7.2 and got the updates
> > from
>
> the
>
> > 7.2 KDE page).
> >
> > _________________________________________________________
> > Tim Harrell
> >
> >
> >
> > --
> > To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
> > For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
> > Also check the FAQ at http://www.suse.com/support/faq and the
> > archives at http://lists.suse.com


--
To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx

Also check the FAQ at http://www.suse.com/support/faq and the
archives at http://lists.suse.com

< Previous Next >
Follow Ups