Mailinglist Archive: opensuse (4053 mails)

< Previous Next >
KDE 2-2 Dependency Hell
  • From: "Harrell, Tim" <HarrelT1@xxxxxxxxxxxxxxxx>
  • Date: Wed, 29 Aug 2001 10:36:16 +0100
  • Message-id: <FC3DA3DC8D4AD311AB910020352A8FDC0594A39B@xxxxxxxxxxxxxxxxxxxxxx>
I have tried to upgrade my KDE 2.1.2 system to KDE 2.2 using all the
base packages supplied on the SuSE KDE Update page.

The problem is that the base packages don't seem to be self-contained.
ie they require capabilities which are not present in the other (2.2)
packages or installed on the existing system.

An example is the kdelibs-artsd package which is one of the requirements
of the 2.2 kdebase (libarts, etc).
This package requires libmcop_mt.so.0.
However none of the other 2.2 packages provide this and it is not on my
system so where am I supposed to find it?

The same is true of cups which requires libcups.so.2

There are lots more examples like this: I had to back out my last
(forced upgrade attempt) by removing and reinstalling KDE 2.1.2 back
onto the system.

So what am I missing guys? (I'm running 7.2 and got the updates from the
7.2 KDE page).

_________________________________________________________
Tim Harrell



< Previous Next >
Follow Ups