Mailinglist Archive: opensuse (4053 mails)

< Previous Next >
RE: [SLE] id respawning too fast errors

I had a similar respawning problem after messing around in YaST, with my 7.2
system. I solved it by booting from the CD, taking the options to update the
system, choosing to update the basic system only (faster than updating all,
and won't overwrite any manually installed application packages you've got
on your system). I don't know if the 6.4 install routine has the same
functionality.

Good luck,

Darrell


-----Original Message-----
From: Prasanna Krishnan [mailto:pkrishnan@xxxxxxxxxxxxxx]
Sent: 20 August 2001 23:57
To: suse-linux-e@xxxxxxxx
Subject: Re: [SLE] id respawning too fast errors




>Prasanna Krishnan a écrit :
>>
>> Hello, I am running SuSE 6.4 with Xfree 4.1.0 and kernel 2.4.7.
>>
>> I was installing some gnome packages yesterday and after I exited yast
the

>>
>> console I was working on froze up, and subsequently the whole computer
went

>>
>> down with the error 'Id Z respawning too fast: disabled for 5 minutes'
where

>>
>> Z is the console id. I rebooted, and this is the output I get:
>> code:
>>
>> Init version 2.78 booting
>> init: Id "1" respawning too fast: disabled for 5 minutes
>> init: Id "2" respawning too fast: disabled for 5 minutes
>> init: Id "3" respawning too fast: disabled for 5 minutes
>> init: Id "4" respawning too fast: disabled for 5 minutes
>> init: Id "5" respawning too fast: disabled for 5 minutes
>> init: Id "6" respawning too fast: disabled for 5 minutes
>>
>> everything is frozen here and I cannot get to my system. I rebooted using

>> the
>> SuSE cd and removed the gnome packages (gnome-vfs, oaf, gconf, and
>> gnome-core).
>> However, this error still persists. I have searched the internet
extensively

>>
>> before posting this. Here are the solutions that I have tried but do not

>> work:
>>
>> 1) Try booting to a different runlevel other than graphical. ie; lilo:
>> 'linux
>> 2'
>> 2) Try booting to single user mode.
>> 3) Try changing the 'respawn' lines in /etc/inittab to 'once'.
>> 4) Reinstalling the SuSE base system
>> 5) Renaming the XF86Config file thinking that it was causing the problem.

>> 6) Reinstalling kdm for above reason.
>>
>> I don't know what to do and I don't know what's causing the problem: X
>> windows
>> or something else (the packages I installed, maybe?).
>>
>> Any help is very much appreciated.
>>
>
> I had the same respawning malancholy issue some weeks ago. It
>was after I had temperd with my /etc/rc.config by the mean of Yast.
>
> I cant remember how I succeded to change back the change I did.
>But it was there :
>
>#
># First you have to edit /etc/inittab to remove the comment of
># the line with /sbin/init.d/rx .
># Then RX_XDMCP and RX_RHOST must be set.
># After all set "yes" if you want to have a X terminal
>#
>START_RX="no" <<<<<««««««««««««««««««
>
>#
># xdm control protocol: "query" or "indirect" or "broadcast"
># For "query" or "indirect" you have to set RX_RHOST
>#
>RX_XDMCP="broadcast"
>
>#
># xdm host, necessary for RX_XDMCP equal "query" or "indirect"
>#
>RX_RHOST=""
>
>#
>
> If you have yast or if you can edit /etc/rc.config and if you
>find START_RX="yes", that is the culprit.
>
> Yes! I remember : appalling experience! My YaST screen
>dreadfully scrambled evry next five minutes of my /etc/rc.config
>scrutiny by a new respawning message.
>
> Not uninteresting too : Midnignt Commander savagely sliced by
>the same respawning thing. When this sort of event is due to some dear
>Jamie Zawinski facetious savory screen. Yes! But when booting or when
>YaSTing it sounds more like a punishment.
>
> Somebody knows a good RESPAWNING-HOWTO somewhere?
>
> O.L.
>
>


I did not have xdmsc (the package which adds those RX lines to rc.config)
installed,
but I booted with the CD, installed it, and then rebooted but it didn't
work.
I checked the rc.config file and START_RX was set to no. Perhaps I should
consider
formatting the just the / partition (/home, /usr/local, and /boot are
separate
partitions) and reinstalling the base? I am not looking forward to doing
that,
but what precautions besides backing up my data should I be taking? Is it
also
wise to install an upgraded version of SuSE or should I just use my 6.4 cd
if
I'm going to do this?
Thank you

Prasanna http://www.bananachipsonline.com

--
To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx

Also check the FAQ at http://www.suse.com/support/faq and the
archives at http://lists.suse.com

********************************************************************************
This electronic mail system is used for information purposes and is
not intended to form any legal contract or binding agreement.
The content is confidential and may be legally privileged. Access
by anyone other than the addressee(s) is unauthorised and any
disclosure, copying, distribution or any other action taken in
reliance on it is prohibited and maybe unlawful
********************************************************************************
< Previous Next >