Mailinglist Archive: opensuse (4053 mails)

< Previous Next >
firewall / ethernet help needed
  • From: Chris Large <clarge@xxxxxxxxxx>
  • Date: Sun, 19 Aug 2001 20:34:42 -0700 (PDT)
  • Message-id: <Pine.LNX.4.10.10108192020340.9779-100000@xxxxxxxxxxxxxxxx>
I just installed version 7.2 on my home machine today. I'm trying to get
the suse firewall to work so i can set up masquarding. I can get eth0 to
work fine off the stock kernel. When i complile in eth1 to the kernel it
is found on reboot with no problems as is eth0.

eth0 does the dhcpclient thing to pull it's address which is seems to do
but there is no routing at all. eth1 seems to be routed right but it
doesn't do a thing.

On closer inspection of the messages from the kernel it seems the eth's
have there io address swaped for some reason. eth0 is a pci ne2000 clone
and eth1 is a isa ne2000 clone but on bootup eth0 seem to have taken eth1
io address.

Yast show them as right. The config files also match the config files from
version 7.0 which worked great with out this problem at all.

If i take eth1 out of the kernel and then reboot eth0 work fine and pulls
an ip address which let me get out to osend this message.

The firewall script works fine as it does it 1st, 2nd, and 3rd run and
show pulling a ip number but nothing is there.

This is the version of suse firewall that comes with 7.2. There was a note
saying i should put date to susefirewall2. Where does one get it as this
sytem at this time still doesn't x window system running.



*--------------------------------*
| Chris Large clarge@xxxxxxxxxx |
| http://clarge.bc.ca |
*--------------------------------*


< Previous Next >
This Thread
  • No further messages