Mailinglist Archive: opensuse (4053 mails)

< Previous Next >
Re: [SLE] WP8 and SuSE 7.2
On Thursday 09 August 2001 22:36, Gary wrote:
> On Thu, Aug 09, 2001 at 07:32:54AM -0700 or thereabouts, Tony Alfrey wrote:
> > "cannot load the library libXpm.so.4"
>
> Hi Tony,
> The way I got it installed is this way, leave the installed WP8 in your
> system. Unlinstall libc5/lib. I think it is called shlibc5. Yes,
> uninstall it, then reinstall it. It should work now. Don't know why
> but it did. <g> I have subsequently moved up to WP2000 suite and this
> works beautifully.

Gary -

thanks for the tip - it got my WP8 working again on 7.2.

A couple of oddities, however. When I did a clean install of 7.2, I installed
shlibs, knowing I would need it for WP8. I then installed my retail copy of
WP8, to be confronted by the "cannot load the library libXpm.so.4" problem. I
managed to get past that by copying libXpm.so.4 and the associated symlinks
over to /usr/lib, from /usr/i486-linux-libc5. However, at that point, when
trying to start the program, I got:

dmgrover@cranky:~ > /opt/wp8/wpbin/xwp
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_pagesize'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_initial_searchlist'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_debug_files'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_nloaded'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_profile'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_global_scope_alloc'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_fpu_control'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_all_dirs'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_load_lock'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_origin_path'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_argv'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_lazy'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_out_of_memory'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_loaded'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_init_all_dirs'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_main_searchlist'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_profile_map'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_clktck'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_profile_output'
/opt/wp8/wpbin/xwp: can't resolve symbol '_dl_platformlen'
/opt/wp8/wpbin/xwp: can't resolve symbol '__libc_stack_end'

After removing shlibs, and deleting libXpm.so.4 and the symlinks from
/usr/lib, and re-installing shlibs, while leaving WP8 in place, it works fine.

I guess what's bugging me is "why?" It almost seems Windows-ish. You know the
routine - uninstalling/re-installing to get a problematic windows app. to
work.

No flame intended towards SuSE, of course. Bottom line is, it got an
application I wanted to work running. Just strikes me as strange. I still
need WP8 for exchanging documents with colleagues who are still using WP7/8
on windows. I guess eventually, when libc5 is no longer available, I'll need
to keep a legacy machine around.

< Previous Next >
This Thread
Follow Ups
References