Mailinglist Archive: opensuse (4053 mails)

< Previous Next >
Re[2]: [SLE] adding sharefont & freefont ?
  • From: Dee McKinney <deem@xxxxxxx>
  • Date: Thu, 9 Aug 2001 08:44:12 -0800 (AKDT)
  • Message-id: <200108091644.f79GiCf15135@xxxxxxxxxxxx>
Ben Rosenberg <ben@xxxxxxxxx> wrote:
> * Dee McKinney (deem@xxxxxxx) [010809 08:38]:
> ->Ass the font packages from GIMP are freefont and sharefont,
> ->is there a quick and dirty way to add these fonts to a stock
> ->7.2 install ? I ran Sax2 and added the directories but they still
> ->don't show up ?
>
> As long as the fonts you installed are in your fontpaths in the XFree86
> config file..you should run SuSEconfig to have it rebuild everything.
> SaX2 won't rebuild the files that show that you have these fonts
> installed.
>

Thanks Ben, SaX2 added the font path to Xfree 4.x generated
file in /etc/X11/XF86Config . This file has text included
saying "DO Not Edit". The stock /etc/XF86Config is for XFree 3.x
and that's not what I'm running. I ran SuSEconfig and still they are
not available to Gimp. Bummer. Here's a clip:

# Automatically generated by SaX2 (4.3)
# PLEASE DO NOT EDIT THIS FILE!
#

<snipped>

FontPath "/usr/X11R6/lib/X11/fonts/sharefont"
FontPath "/usr/X11R6/lib/X11/fonts/freefont"

So they are in the config file OK, and they .fontdir files also.

Any other idea ?

Thanks
/Dee


< Previous Next >
Follow Ups
References