Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
Re: [SLE] NVIDIA drivers (again!) and unresolved symbols
  • From: Mark Hounschell <markh@xxxxxxxxxx>
  • Date: Thu, 31 May 2001 07:54:51 -0400
  • Message-id: <3B16310B.6D04AF62@xxxxxxxxxx>
Ben Rosenburg wrote:
> > Solution:
> >
> > 1. Get kernel 2.4.4's RPM /pub/people/mantel/next/RPM
> > A. Install this.
> > 2. Get kernel 2.4.4's tar.gz /pub/people/mantel/next
> > 3. Unzip the tar.gz kernel src in /usr/src and replace the link so that
> > it points to the new src.
> > 4. Get the tar.gz files of the nVidia driver and GLX.
> > 5. mv them to /usr/src and untar them.
> > 6. cd into the kernel module directory and make the module
> > 7. Do the make install for the GLX.
> > 8. Search the archives for the modified switch2nv_glx and use this.
> > 9. It will work. I have NO problems ..with or without KDM.
> >
> > Unresolved symbols stem from a mismatch of src. If you don't have the
> > same src that your compiling the module against as your running kernel
> > is using..then the module will be hella fucked up and won't work. These
> > drivers work. The kernel works. Doing it right makes it work.
> >
> >
> The unresolved symbols problem has been fixed. Read the thread closer.
> We are
> now only having problems with the use of a cleanly built/installed
> driver. Your
> solution will do nothing to fix this other problem that we are having
> with it.
> Although I've been meaning to try that particular kernel for other
> reasons.
> We'll see. But our problem now is not an unresolved symbol problem. It's
> something
> else that appears just to be the driver it's self.

Well I've tried mantels kernel and all and it does not make any
differenc.
I can live with these issues myself. As long as my 3d works and my
machine
doesn't hang I can live with it.

Regards
Mark

< Previous Next >
Follow Ups