Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
SSH 2.4 and 7.1
  • From: "Felipe Blanco" <iolistas@xxxxxxxxxxxxx>
  • Date: Wed, 23 May 2001 16:58:31 +0200
  • Message-id: <017001c0e398$d4da8a00$364ca3d4@xxxxxxxxxxxx>
Hi all .

First, sorry for my english ;)

Maybe someone in the list have problems trying to compile ssh 2.4.0 with
suse 7.1 ?
Im trying this since yesterday and find a lot of problems that in suse 7.0
dont have.

Look this

make[4]: Leaving directory `/tmp/backup/ssh-2.4.0/apps/ssh/tests'
make[4]: Entering directory `/tmp/backup/ssh-2.4.0/apps/ssh'
gcc -D_GNU_SOURCE -g -O2 -Wall -Wno-unknown-pragmas -o sshd2
sshd2.o -L. -L../../lib -lssh2 -lssh -lnsl -L/usr/local/lib -lcrypt -lncurse
s -lm -lnsl -lutil
./libssh2.a(auths-pam.o): In function `ssh_pam_auth_successful':
/tmp/ssh-2.4.0/apps/ssh/auths-pam.c:450: undefined reference to
`ssh_user_pam_set_handle'
collect2: ld returned 1 exit status
make[4]: *** [sshd2] Error 1
make[4]: Leaving directory `/tmp/backup/ssh-2.4.0/apps/ssh'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/tmp/backup/ssh-2.4.0/apps/ssh'
make[2]: *** [all-recursive] Error 1

Seems like if its problem with PAM libreries maybe ,but i dont know.
I have the pam libraries installed and all works ok but its impossible to
compile this.
I`ve tried to compile with flags omitting the pam authentication and tell me
the same .
I have installed ssh1 , the package that comes with the distribution,i`ve
tried deleting it and trying to compile ssh2 and still crash.
Someone tells me to try to install or uninstall the cross compilators that
came with the new distro but still the same...

What a hell...

TIA for the possible answers

Felipe Blanco






< Previous Next >
Follow Ups