Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
Re: [SLE] Kernel upgrade and disappearing modules.dep
On Monday 21 May 2001 03:34, you wrote:
> Hi. I've got a SuSE 6.4 system running the standard kernel. I've just
> tried to upgrade to 2.4.2, as present in the 7.1 update area, to see if I
> can get my TV card to work. I downloaded the 2.4.2 default kernel RPM, and
> the 2.4.2 modutils RPM, and installed them both. I then edited lilo.conf
> to use the new kernel image, and re-ran lilo.
>
> On re-booting, the system complained that
> /lib/modules/2.4.2-4GB/modules.dep (path may not be correct, but it was
> definitely modules.dep) was missing. This was installed from the kernel
> package, so, thinking something went wrong, I installed it again, re-ran
> LILO, and rebooted.
>
> On boot, I got the same error. After a couple of iterations, I confirmed
> that somewhere in the "install package - re-run LILO - reboot" cycle, the
> modules.dep file disappears. None of the modules.dep files disappear from
> my other kernel module areas, so this appears to be peculiar to my 2.4.2
> kernel.
>
> Does anyone have any ideas?

Greetings! I`ve done the same but before rebooting again run "depmod "
command!No problems afterwards. See ya Alan

PS:I didnot upgrade the kernel just installed it as additional so Ican have
an option to boot either.It works just fine

< Previous Next >
References