Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
Re: [SLE] UT fails to start
That worked!

It loads the map now but I am getting a totally new error message.

At the end of the message I get:

Input system initialized for SDLViewport0
Opening SDL viewport.
Bound to SDLGLDrv.so
Loaded render device class.
Initializing SDLGLDrv...
binding libGL.so.1
Resizing SDL viewport. X: 640 Y: 480
OpenGL
appError called:
Couldn't set video mode: Couldn't find matching GLX visual

Executing UObject::StaticShutdownAfterError
Executing USDLClient::ShutdownAfterError
Executing USDLViewport::ShutdownAfterError
USDLGLRenderDevice::ShutdownAfterError
Signal: SIGIOT [iot trap]
Aborting.
Exiting.
Name subsystem shut down

Not sure what this all about, I think its possibly a driver issue, but
again, not sure of it.

I am using a Matrox G450 with the GLX drivers running in X.

I will still be looking, but if anyone is familiar with it, any help
would be appreciated!

Robert K Davies

On 21 May 2001 20:24:09 +0200, S. Bulterman wrote:
> The problem is that the map files are not decompressed......
> Use this script to decompress the maps......
>
> Not my doing but made by somebody on the news://loki.games.ut list
>
> -------copy and past this bash script---------------
> #!/bin/sh
> # Change this to YOUR install-dir of UT
> #
> INSTALLDIR=/usr/local/games/ut
>
> cd $INSTALLDIR/System
>
> for i in `ls ../Maps/*.unr.uz`
> do
> ucc decompress ../Maps/$i -nohomedir
> done
>
> rm ../Maps/*unr.uz
> mv *.unr ../Maps
>
> echo "..:: Done! ::.."
> -------copy and past this bash script---------------
>
> Phantasm wrote:
>
> > Hello,
> >
> > With all this talk of UT, I decided to give it a run and install it.
> >
> > Everything appears to install fine, but when I run it I get this error
> > message.
> >
> > phantasm@office:~ > ut
> > Creating preferences directory...
> > Creating directory /home/phantasm/.loki/ut/
> > Creating directory /home/phantasm/.loki/ut/System
> > Unreal engine initialized
> > Bound to SDLDrv.so
> > Joystick [0] : Unknown Joystick
> > SDLClient initialized.
> > Bound to Render.so
> > Lighting subsystem initialized
> > Rendering initialized
> > LoadMap: Entry
> > Failed to load 'Entry': Can't find file 'Entry'
> > Failed to load 'Level None.MyLevel': Can't find file 'Entry'
> > appError called:
> > Failed to enter Entry: Can't find file 'Entry'
> > Executing UObject::StaticShutdownAfterError
> > Executing USDLClient::ShutdownAfterError
> > Signal: SIGIOT [iot trap]
> > Aborting.
> > Exiting.
> > Name subsystem shut down
> >
> > Now when I check the /usr/local/games/ut/Maps directory Entry.unr.uz
> > exists so what could I be missing?
> >
> > Thanks in advance!
> > ~Robert K Davies
> >
> > --
> > To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
> > For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
> > Also check the FAQ at http://www.suse.com/support/faq and the
> > archives at http://lists.suse.com
>
> --
> Thanks in advance,
> Stefan
> --------------------------------------------------------------
> Linux a world without borders, fences, windows and gates.....
> Titanic98 "Which computer do you want to sink today????"
>
>
>
> --
> To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
> For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
> Also check the FAQ at http://www.suse.com/support/faq and the
> archives at http://lists.suse.com
>
< Previous Next >
Follow Ups