Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
Serial Connection Problem on thinkpad 380ed
  • From: Ali BASEL <alib@xxxxxxxxxxxxxxx>
  • Date: Mon, 21 May 2001 15:25:08 +0300
  • Message-id: <3B090924.B154D5B4@xxxxxxxxxxxxxxx>
Hi,
I've installed SuSE 7.1 on my thinkpad 380ED, on the second partition to

configure our cisco switches and routers. (I am using the windows98 with

hyperterminal on the same thinkpad without any problem).

But, the minicom (1.83.1) can't communicate with the switch.
I have installed Suse 7.1 on a desktop pc and made the same minicom
configuration (/dev/ttyS0, 9600 8N1) and it worked without any problem.

I tried the tptcl program for thinkpad:
alibl:~ # tpctl --rsx
resource state: current
serial port 1: disable 0x0 IRQ0
serial port 2: enable 0x3f8 IRQ4
and I tried to enable the serial port 1:

alibl:~ # tpctl --rs1=0x2f8 --rs1=irq3 --rs1=enable
tpctl: serial port 1 has been enabled
tpctl: serial port 1 interrupt has been set to IRQ3
tpctl: serial port 1 base address has been set to 0x2f8
resource state: current
serial port 1: disable
0x0 IRQ0

As you see, no thing changes.

Do you have an idea ?
--
Ali BASEL
Sabanci University
Information Technology
http://people.sabanciuniv.edu/~alib



< Previous Next >
Follow Ups