Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
Re: [SLE] Kernel upgrade and disappearing modules.dep
  • From: "Harold !" <ambrosius1972@xxxxxxxxxxx>
  • Date: Sun, 20 May 2001 14:16:47 -0500
  • Message-id: <F183kzpB8JPGbFqTnrr00006b2e@xxxxxxxxxxx>
2.4.2 needs mk_initrd ran after update and then lilo
;-)
Ambrosius


From: Dave Smith <Dave.Smith@xxxxxx>
To: suse-linux-e@xxxxxxxx
Subject: [SLE] Kernel upgrade and disappearing modules.dep
Date: Sun, 20 May 2001 19:04:14 +0100
MIME-Version: 1.0
Received: from [202.58.118.3] by hotmail.com (3.2) with ESMTP id MHotMailBCD1523000394004379DCA3A760308CC0; Sun May 20 11:04:32 2001
Received: (qmail 30579 invoked by alias); 20 May 2001 18:04:23 -0000
Received: (qmail 30572 invoked from network); 20 May 2001 18:04:23 -0000
From suse-linux-e-return-58093-ambrosius1972 Sun May 20 11:05:00 2001
Mailing-List: contact suse-linux-e-help@xxxxxxxx; run by ezmlm
Precedence: bulk
X-No-Archive: yes
list-help: <mailto:suse-linux-e-help@xxxxxxxxxxxxxx>
list-unsubscribe: <mailto:suse-linux-e-unsubscribe@xxxxxxxxxxxxxx>
list-post: <mailto:suse-linux-e@xxxxxxxx>
X-Mailinglist: suse-linux-e
Delivered-To: mailing list suse-linux-e@xxxxxxxxxxxxxx
Recieved: from Dave.Smith@xxxxxx by sulphur with local (Exim 3.03 #5)id 151XYs-0002Lj-00for suse-linux-e@xxxxxxxx; Sun, 20 May 2001 19:04:14 +0100
Message-ID: <20010520190414.O12677@xxxxxxxxxxxxxx>
X-Mailer: Mutt 1.0.1i

Hi. I've got a SuSE 6.4 system running the standard kernel. I've just tried
to upgrade to 2.4.2, as present in the 7.1 update area, to see if I can get
my TV card to work. I downloaded the 2.4.2 default kernel RPM, and the 2.4.2
modutils RPM, and installed them both. I then edited lilo.conf to use the
new kernel image, and re-ran lilo.

On re-booting, the system complained that /lib/modules/2.4.2-4GB/modules.dep
(path may not be correct, but it was definitely modules.dep) was missing.
This was installed from the kernel package, so, thinking something went
wrong, I installed it again, re-ran LILO, and rebooted.

On boot, I got the same error. After a couple of iterations, I confirmed
that somewhere in the "install package - re-run LILO - reboot" cycle, the
modules.dep file disappears. None of the modules.dep files disappear from
my other kernel module areas, so this appears to be peculiar to my 2.4.2
kernel.

Does anyone have any ideas?


--
David Smith Tel: +44 (0)1454 462380 (direct)
STMicroelectronics Fax: +44 (0)1454 617910
1000 Aztec West TINA (ST only): (065) 2380
Almondsbury Home: 01454 616963
BRISTOL Mobile: 07932 642724
BS32 4SQ Work Email: Dave.Smith@xxxxxx
Home Email: David.Smith@xxxxxxxxxxxxxxxxxxxx

--
To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the FAQ at http://www.suse.com/support/faq and the
archives at http://lists.suse.com


_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com


< Previous Next >
Follow Ups