Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
Re: [SLE] Kernel upgrade and disappearing modules.dep
Report this to SuSe Support. This happened to me also and hosed my sys.
You Can refer them to me as well in the report. It maybe that they need to
update the HOWTO or sdb on kernel upgrades or there is a flaw. I was told by
someone on the list to back up the modules.conf and one other file, can't
remember which. Note: Since this is not related to a stock install they my
send you a generic support letter stating as much.

You can find the support tool under
Start-->SuSE-->admin-->uspecified-->support.
HTH, Cheers. Curtis Rey


On Sunday 20 May 2001 13:04, Dave Smith wrote:
> Hi. I've got a SuSE 6.4 system running the standard kernel. I've just
> tried to upgrade to 2.4.2, as present in the 7.1 update area, to see if I
> can get my TV card to work. I downloaded the 2.4.2 default kernel RPM, and
> the 2.4.2 modutils RPM, and installed them both. I then edited lilo.conf
> to use the new kernel image, and re-ran lilo.
>
> On re-booting, the system complained that
> /lib/modules/2.4.2-4GB/modules.dep (path may not be correct, but it was
> definitely modules.dep) was missing. This was installed from the kernel
> package, so, thinking something went wrong, I installed it again, re-ran
> LILO, and rebooted.
>
> On boot, I got the same error. After a couple of iterations, I confirmed
> that somewhere in the "install package - re-run LILO - reboot" cycle, the
> modules.dep file disappears. None of the modules.dep files disappear from
> my other kernel module areas, so this appears to be peculiar to my 2.4.2
> kernel.
>
> Does anyone have any ideas?

< Previous Next >
Follow Ups
References