Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
Kernel upgrade and disappearing modules.dep
  • From: Dave Smith <Dave.Smith@xxxxxx>
  • Date: Sun, 20 May 2001 19:04:14 +0100
  • Message-id: <20010520190414.O12677@xxxxxxxxxxxxxx>
Hi. I've got a SuSE 6.4 system running the standard kernel. I've just tried
to upgrade to 2.4.2, as present in the 7.1 update area, to see if I can get
my TV card to work. I downloaded the 2.4.2 default kernel RPM, and the 2.4.2
modutils RPM, and installed them both. I then edited lilo.conf to use the
new kernel image, and re-ran lilo.

On re-booting, the system complained that /lib/modules/2.4.2-4GB/modules.dep
(path may not be correct, but it was definitely modules.dep) was missing.
This was installed from the kernel package, so, thinking something went
wrong, I installed it again, re-ran LILO, and rebooted.

On boot, I got the same error. After a couple of iterations, I confirmed
that somewhere in the "install package - re-run LILO - reboot" cycle, the
modules.dep file disappears. None of the modules.dep files disappear from
my other kernel module areas, so this appears to be peculiar to my 2.4.2
kernel.

Does anyone have any ideas?


--
David Smith Tel: +44 (0)1454 462380 (direct)
STMicroelectronics Fax: +44 (0)1454 617910
1000 Aztec West TINA (ST only): (065) 2380
Almondsbury Home: 01454 616963
BRISTOL Mobile: 07932 642724
BS32 4SQ Work Email: Dave.Smith@xxxxxx
Home Email: David.Smith@xxxxxxxxxxxxxxxxxxxx

< Previous Next >
Follow Ups