Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
booting a modular kernel
  • From: Jim Osborn <jimo@xxxxxxxxxx>
  • Date: Mon, 7 May 2001 22:43:22 -0700 (PDT)
  • Message-id: <200105080543.WAA17595@xxxxxxxxxx>
I tried compiling a kernel from source---I know SuSE officially
discourages anything but the standard distro kernel, but I've enjoyed
kernels compiled specifically for the machine in the past, and if I
want to patch a kernel for whatever reason, I'll need to compile,
etc. This machine runs from a scsi bus, so it needs to use initrd
during boot if the scsi driver is configured as a module. That's the
way the SuSE 6.3 2.2.13 kernel is configured, and that's the way I
configured the new one.

Naturally, I want to keep my old, working kernel in place as
a backup. I need to know how to use mk_initrd, if necessary,
to make the ramdisk image for the new kernel, but I need also
to know what to do to preserve the /boot/initrd image for my
old kernel. SuSE 6.3 came with no documentation on mk_initrd;
there's an ancient man page for initrd, from 1997, but it
doesn't provide any real help for mk_initrd. Invoking mk_initrd
with --help gives "usage: mk_initrd [root_dir]" which doesn't
give me much help in supporting two kernels. RedHat's version,
called mkinitrd, is significantly different from SuSE's mk_initrd.

Maybe it's possible I can use the same /boot/initrd image for all
kernels, but so far, I can't seem to make it work---every
configuration I've tried ends with a kernel panic:
"VFS: Cannot open root device 08:02"
which is the root partition on the scsi hard disk. rdev
gives the same info for both the old and new kernels.

Has anyone successfully compiled (and run) a kernel on a SuSE system?

Have you done it in a situation where initrd was necessary?

Does anyone have any documentation on mk_initrd?

TIA,

Jim

< Previous Next >