Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
Re: [SLE] PCNet32 driver
  • From: Juergen Braukmann <juergen.braukmann@xxxxxxxxxxxx>
  • Date: Sun, 06 May 2001 09:59:16 +0200
  • Message-id: <3AF50454.2939B134@xxxxxxxxxxxx>
Lenz Grimmer wrote:
>
> On Fri, 4 May 2001, Derek Fountain wrote:
>
> > Anyone on the list running kernel 2.4 with the pcnet32 network driver?
> > People around here are having problems with a freshly compiled 2.4.3
> > kernel. (The module loads, but it gives an "SIOCSIFFLAGS: Invalid
> > argument" error when trying to get the interface up.)
> >
> > Can someone just confirm that the driver isn't broken, and that it
> > will be made to work if we fiddle with it enough?
>
> Does it provide any additional error messages in /var/log/messages?
>
> LenZ

Hi Derek, Hi Lenz,

Coincedently I was experimenting with pcnet32 (Compaq 5133... ;-(() on
friday. I cannot say wether it was 2.4 or 2.2. We also ran into trouble.
We want to use the RJ45 port, not the default AUI port. There must be
options to do that, but I could not find it. We ended up digging the
source, we found our information. (add options=1..16) It didn't work.
With a wrong parameter (=! options=) the module complained. With
"options=1" it would produce sort of error / segfault but load flawless
on the second try. Of course, network didn't work then.
I'll have another chat with my collegues on monday to see what came out.

I have an other Compaq running fine with pcnet32, but on 2.2.X (SuSE
7.0) and on the AUI port.

Juergen

--
=========================================== __ _
Juergen Braukmann juergen.braukmann@xxxxxx| -o)/ / (_)__ __ ____ __
Tel: 0201-743648 dk4jb@db0qs.#nrw.deu.eu | /\\ /__/ / _ \/ // /\ \/ /
===========================================_\_v __/_/_//_/\_,_/ /_/\_\

< Previous Next >
References