Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
mounting a cramfs image OR cramfs on disk
  • From: phantasm <phantasm@xxxxxxxxxxxx>
  • Date: Thu, 03 May 2001 14:09:16 -0400
  • Message-id: <3AF19ECC.5060506@xxxxxxxxxxxx>
Ok I got what I needed off the Compact Flash card I was using, I used dd to extract the information and store it as a *img file in my home directory.

Now I re-did my kernel to use Compressed ROMFS Support (cramfs) and tried using mount -o loop -t cramfs /root/flash.img /mnt/flashcard and that locks up mount to where I can't even kill -9 the pid. I have tried putting -o loop in misc places all with the same result

using:

root@office:~ > mount -t cramfs /root/flash.img /mnt/flashcard
mount: /root/flash.img is not a block device (maybe try `-o loop'?)

and again when I use -o loop it locks and can't be killed.

I decided to try a different method where I dd if=/root/flash.img of=/dev/hdc1 which puts in a few thousand records (65K) and exits normally.

but once I do that I use mount -t cramfs /dev/hdc1 /mnt/flashcard and it says

root@office:~ > mount -t cramfs /dev/hdc1 /mnt/babygfs
mount: wrong fs type, bad option, bad superblock on /dev/hdc1,
or too many mounted file systems

I checked the image with khex edit, and in there, there are references to a Compressed ROMFS and shows a directory structure in the mix os everything, so I know there is something in there.

I am going crazy trying to find an answer to mouting this, ANY help would be appreciated greatly!

Robert Kris Davies


< Previous Next >
This Thread
  • No further messages