Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
Re: [SLE] How important is it to not user gcc2.95.2 for kernel 2.4?
You should use gcc 2.95.3 -- look in ftp.suse.com/pub/people/pthomas.
> IIRC the good Mr. Thomas provided update rpm's for us :-)

Well That's Good , but is it any better than 2.95.2 ??
Is there any more info - or should we trust by blind faith, that it will
not cause problems that 2.95.2 may.
What parts of compiling a kernel could there be some affect ?

Why is ergs circa 1999 , the prefered choice in the /usr/src/linux/documentation/changes ?
egcs 1.1.2 (gcc 2.91.66) - <ftp://sourceware.cygnus.com/pub/gcc/releases/egcs-1.1.2/egcs-1.1.2.tar.bz2>
I can probably answer this myself - because it was a damn good compiler. But who would have known
that it could be used to compile the latest kernels .? especially with all the 'updating hype' going on
reminds me of -m$ I know don't say it .
-semi-rant-
Else I would not have updated to gcc2.95.2 -which is not as good as egcs 1.1.2 .

By the time I find this out , I have already compiled kernels 4 times using 2.95.2
I have had quite dubious results. see on this list - the many, ''problems compiling . . .''
messages posted - march-april - .
Dubious results may or may not have been caused by the compiler though -
but I wish I knew more of what is at fault so I can get on with making my cottage cheese : \
So lets talk compilers once in a while here on the list .

-end-semi-rant-

> > Quote from ''Just Another SuSE User''
>The docs for kernel-2.4.4 say to not use 2.95.2 but use 2.91.66 instead?
> > If I must use the older compiler, can I install this along side 2.95.2
> > and if so, how do I build using it instead?

Well I have an egcs 1.1.2 (gcc 2.91.66) untared and ready to use /usr/src/egcs 1.1.2 .
I guess the best way is to try to compile with it , and decide for myself that it suites my needs.
I can always re-install gcc2.95.3rpm .

You could install the available 2.95.3rpm from ftp.suse.com/pub/people/pthomas
and just compile as usual to try it out . Looks like you shouldn't be using 2.95.2
any more now that we know there could be problems with it.

John W Mislan

On Wed, 02 May 2001, Mads Martin Jørgensen wrote:
> * Just Another SuSE User <suse@xxxxxxxxxx> [May 02. 2001 12:23]:
> >
> >
> > The docs for kernel-2.4.4 say to not use 2.95.2 but use 2.91.66 instead?
> > If I must use the older compiler, can I install this along side 2.95.2
> > and if so, how do I build using it instead?
>
> You should use gcc 2.95.3 -- look in ftp.suse.com/pub/people/pthomas.
> IIRC the good Mr. Thomas provided update rpm's for us :-)
>
> --
> Mads Martin Joergensen, http://mmj.dk
> "Why make things difficult, when it is possible to make them cryptic and
> totally illogic, with just a little bit more effort."
> -- A. P. J.
>
> --
> To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
> For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
> Also check the FAQ at http://www.suse.com/support/faq and the
> archives at http://lists.suse.com
--

God does not play dice" -- Einstein
"Not only does God play dice, he sometimes throws
them where they can't be seen." -- Stephen Hawking



< Previous Next >