Mailinglist Archive: opensuse-buildservice (66 mails)

< Previous Next >
[opensuse-buildservice] Patchinfo usage, downgrading via maintenance process
  • From: Morschhäuser, Mark <Mark.Morschhaeuser@xxxxxx>
  • Date: Mon, 7 Sep 2020 11:09:32 +0000
  • Message-id: <90b1ed81405e4c79a9c70ae8687d5429@mailex1a.dsa.local>
Hi,

we made a distribution release with our OBS instance where we included a
package in a version that has to be downgraded now.
Say we included foo 5.0 in the distribution but want to downgrade to 4.9,
codefreeze is passed, project is locked, first distributions are shipped.
Can the patchinfo checkbox "Block release?" be used for that? Like creating a
maintenance release for foo 5.0 with that checkbox enabled and then create a
maintenance release for foo 4.9?
I had success with repository priorities but that requires that the software is
not yet installed to prefer the lower version.
And zypper does not support a "ignore foo >= 5.0" syntax as it seems to ignore
certain packages.

Best regards,

Mark
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >