Mailinglist Archive: opensuse-buildservice (144 mails)

< Previous Next >
[opensuse-buildservice] Why does OBS think some packages are "unresolvable" while they are not?
Hi there,

I've given up (I think) trying to understand why OBS sometimes behaves
different than what I'd expect.

Here is my (current) challenge:

I'm trying to build firefox69 in my own project in
home:manfred-h:mozilla. The repository metadata is set up as follows:

$ osc meta prj home:manfred-h:mozilla
<project name="home:manfred-h:mozilla">
<title>mozilla</title>
<description>
Mozilla based projects and support packages.
</description>
<person userid="manfred-h" role="maintainer"/>
<build>
<disable/>
</build>
<repository name="openSUSE_Leap_42.3">
<path project="home:manfred-h:devel:languages:rust"
repository="openSUSE_Leap_42.3"/>
<path project="mozilla" repository="openSUSE_Leap_42.3"/>
<path project="openSUSE:Leap:42.3:Update" repository="standard"/>
<path project="openSUSE:Leap:42.3" repository="standard"/>
<arch>x86_64</arch>
</repository>
<repository name="openSUSE_Leap_15.1">
<path project="devel:languages:rust" repository="openSUSE_Leap_15.1"/>
<path project="mozilla" repository="openSUSE_Leap_15.1"/>
<path project="openSUSE:Leap:15.1:Update" repository="standard"/>
<path project="openSUSE:Leap:15.1" repository="standard"/>
<arch>x86_64</arch>
</repository>
<repository name="openSUSE_Leap_15.0">
<path project="home:manfred-h:devel:languages:rust"
repository="openSUSE_Leap_15.0"/>
<path project="mozilla" repository="openSUSE_Leap_15.0"/>
<path project="openSUSE:Leap:15.0:Update" repository="standard"/>
<path project="openSUSE:Leap:15.0" repository="standard"/>
<arch>x86_64</arch>
</repository>
</project>

As you can see, nothing should get build by default (this is enabled
purely on a package by package case) and repositories are setup so
that "rust" and related packages should be taken from

- devel:languages:rust for openSUSE_Leap_15.1
- home:manfred-h:devel:languages:rust for 42.3 and 15.0

firefox69 now needs rust-cbindgen >= 0.9.0, so I copied that package to
my home:manfred-h:devel:languages:rust as rust-cbindgen-0.9.0 and built
it there successfully for openSUSE_Leap_42.3 and openSUSE_Leap_15.0

Still OBS thinks "nothing provides rust-cbindgen >= 0.9.0" for 15.0 and
42.3, but the packages are there:


<https://build.opensuse.org/package/binary/home:manfred-h:devel:languages:rust/rust-cbindgen-0.9.0/openSUSE_Leap_15.0/x86_64/rust-cbindgen-0.9.0-lp150.1.1.x86_64.rpm>

<https://build.opensuse.org/package/binary/home:manfred-h:devel:languages:rust/rust-cbindgen-0.9.0/openSUSE_Leap_42.3/x86_64/rust-cbindgen-0.9.0-1.1.x86_64.rpm>

both providing:

rust-cbindgen = 0.9.0-1.1
rust-cbindgen(x86-64) = 0.9.0-1.1

FWIW, as a last resort, I linked my rust-cbindgen-0.9.0 package to
rust-cbindgen in the home:manfred-h:devel:languages:rust project, but
this did not change anything unfortunately.

Can anybody tell me what I'm doing wrong here? Or is this a bug in the
OBS resolver?

TIA, cheers.

l8er
manfred

PS: No complaints wrt/ 42.3, I'm not yet done with migrating all systems
I maintain to 15.1 yet! Therefore I'm trying to keep those packages
still building which are not services but still as close to the
Internet as possible, i.e. the _bad world_ ;)
< Previous Next >