Mailinglist Archive: opensuse-buildservice (145 mails)

< Previous Next >
[opensuse-buildservice] Prjconf Prefer
  • From: Darin Perusich <darin@xxxxxxxxxx>
  • Date: Thu, 17 Oct 2013 08:39:04 -0400
  • Message-id: <CADaviKt296_kPb5cMLN1EZGt5mSt06ociT2CW6wm=HoMsn3zxQ@mail.gmail.com>
Hello All,

I'm trying to work around an issue in devel:lang:perl for SLE_SP3
where perl provides an old version of perl(version) which is causing
numerous build failures. The prjconf documentation says you can use
Prefer to choose a different package for a dependency, but I've set
the below Prefer value but I'm still getting "provider perl-version is
obsoleted by installed perl".

Can someone provide some guidance on this?

%if 0%{?suse_version} <= 1110
Prefer: perl:perl-version
%endif

http://en.opensuse.org/openSUSE:Build_Service_prjconf#Prefer

--
Later,
Darin
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages