Mailinglist Archive: opensuse-buildservice (145 mails)

< Previous Next >
Re: [opensuse-buildservice] Re: obs build changing devpts mount opts
FWIW,

I have released a new build package that adjusts the permissions
for 12.2 and 12.3 last week.

Ciao, Marcus
On Wed, Oct 02, 2013 at 04:22:42PM -0400, Darin Perusich wrote:
I've create bug 843775 for this.

https://bugzilla.novell.com/show_bug.cgi?id=843775
--
Later,
Darin


On Wed, Oct 2, 2013 at 3:41 PM, Darin Perusich <darin@xxxxxxxxxx> wrote:
Hello All,

I was building some packages locally afterward/during I started having
this problem where when I'd open a new konsole it would just be blank
and it seemed like the only way to get my system back in order was to
reboot. After some digging I've determined that after running "obs
build openSUSE_12.3" the mount opts of devpts are changing to
"rw,relatime,mode=600,ptmxmode=000" from
"rw,relatime,gid=5,mode=620,ptmxmode=000"

This appears to be related to a glibc update released the other day
and how "osc build" does it's chroot, "mount -n -tdevpts none
$BUILD_ROOT/dev/pts". A quick work around is to "mount -oremount
/dev/pts" should anyone else get hit by this. I haven't filed a bug
yet but it's coming.

http://sourceware.org/ml/libc-alpha/2013-08/msg00454.html
http://lists.opensuse.org/opensuse-updates/2013-09/msg00072.html

--
Later,
Darin
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >