Mailinglist Archive: opensuse-buildservice (233 mails)

< Previous Next >
Re: [opensuse-buildservice] Debian build issues
  • From: Michael Schroeder <mls@xxxxxxx>
  • Date: Mon, 7 May 2007 16:09:18 +0200
  • Message-id: <20070507140918.GA21810@xxxxxxx>
On Mon, May 07, 2007 at 03:54:11PM +0200, Amilcar do Carmo Lucas wrote:
> Hi,
> 
> I've read http://en.opensuse.org/Build_Service/Deb_builds
> It is a nice tutorial, but an example and some more details are missing,
> my project used to build debian and Ubuntu packages before those build-service 
> improvments.
> 
> I found a example project that seams to use the new features and
> I used http://build.opensuse.org/project/show?project=home%3Afcarlier as ;
> template for my debian builds.
> 
> But it still does not work :(
> 
> Here is my project
> http://build.opensuse.org/package/show?package=KDevelop3&project=home%3Aamilcarlucas
> I get:
> nothing provides kdelibs-data > 4:3.5.5a.dfsg.1 needed by kdelibs4c2a

Oh no, it seems to me like this is caused by incompatibilities between the
rpm version compare mechanism and the one from debian.

kdelibs4c2a_3.5.5a.dfsg.1-8 contains:
Depends: kdelibs-data (>> 4:3.5.5a.dfsg.1), kdelibs-data (<< 4:3.5.5a.dfsg.2)

This is not solvable with the rpm mechanism, where
"kdelibs-data > 4:3.5.5a.dfsg.1" is not true for "kdelibs-data_3.5.5a.dfsg.1-8"
(which seems pretty reasonable to me).
Seems like debian treats this different, is there any debian expert out
there who can confirm that?

Cheers,
  Michael.

-- 
Michael Schroeder                                   mls@xxxxxxx
SUSE LINUX Products GmbH, GF Markus Rex, HRB 16746 AG Nuernberg
main(_){while(_=~getchar())putchar(~_-1/(~(_|32)/13*2-11)*13);}
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups