Mailinglist Archive: zypp-devel (18 mails)

< Previous Next >
RE: [zypp-devel] Any better way to set proxy for libzypp
On Mon, 2011-04-18 at 17:48 +0800, Zhang, Qiang Z wrote:
Libzypp seems can't work with root, and PackageKit runs as root, so

Zypp backend can't work well with libproxy.

What?

The zypp backend works *fine* with libproxy, whether you are root or
not.

I *think* what you're trying to say here is that you have been using a
version of libproxy which was configured wrongly when you run it as
root. That is nothing to do with libzypp; that's just that you have
misconfigured it.

If you have a libproxy that's just talking to PacRunner, everything
works *fine*.

--
dwmw2

--
To unsubscribe, e-mail: zypp-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: zypp-devel+help@xxxxxxxxxxxx

< Previous Next >