Mailinglist Archive: zypp-devel (26 mails)

< Previous Next >
Re: [zypp-devel] Re: FW: Bug maybe? zypper lu
  • From: Elmar Stellnberger <estellnb@xxxxxxxxx>
  • Date: Tue, 25 Aug 2009 11:12:53 +0100
  • Message-id: <4A93B925.4060109@xxxxxxxxx>
try 'zypper lu | lv' instead.
lv supports ansi escape characters; less does not.
This is rather a 'bug' of less than a problem of zypper since a pure
'zypper lu' should give a colored output as well.

Coloring makes the output of terminal programs much more readable.
I would welcome this to be used much more heavily.
If we wanna do sth. about that issue, we should at first install lv by
default and perhaps then modify less to interprete ANSI-escape-sequences
correctly since that is easier than making all users learn about a new
program like lv.

For a guide on how to use ANSI-escape-sequences with your own Linux
programs just have a look at http://www.elstel.com/ColorConsole (page
will go online, soon; in a day or so.).


Duncan Mac-Vicar Prett schrieb:
On Monday 24 August 2009 21:32:17 Vickers, Mark wrote:
What is the cruft before the work "Repository"

zypper lu |less


Reading installed packages...
Patches

ESC[?1034hRepository | Name | Version | Category | Status
-----------------+------+---------+----------+-------
Updates for 11.0 | hal | 620 | security | Needed


zypper --version
zypper 0.11.11

Color output your terminal does not seem to support. I have the same problem
always with git diff ;-)



--
To unsubscribe, e-mail: zypp-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: zypp-devel+help@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups