Mailinglist Archive: zypp-devel (70 mails)

< Previous Next >
[zypp-devel] How to fix the endless dependency loops?
  • From: Aniruddha <mailing_list@xxxxxxxxx>
  • Date: Sun, 28 Oct 2007 16:34:34 +0100
  • Message-id: <1193585674.3506.42.camel@xxxxxxxxxxxx>
When I run '# zypper update -t package' I get stuck
in an endless dependency loop. How do we fix this?

# zypper update -t package

2 Problems:
Problem: No valid solution found with just resolvables of best
architecture.
Problem: Cannot install wesnoth-data-base, because it is conflicting
with wesnot
h-data

Problem: No valid solution found with just resolvables of best
architecture.
With this run only resolvables with the best architecture have been
regarded.
Regarding all possible resolvables takes time, but can come to a valid
result.
Solution 1: Make a solver run with ALL possibilities.
Regarding all resolvables with a compatible architecture.
number, (r)etry or (c)ancel> 1
Applying solution 1

......

Solution 1: do not install wesnoth-data-base
do not install wesnoth-data-base-1.2.7-3.1.noarch[Games_Turn-Based]
Solution 2: do not install wesnoth-data
do not install wesnoth-data-1.3.9-12.1.noarch[Games_Turn-Based]
Solution 3: Ignore this conflict of wesnoth-data-base
number, (r)etry or (c)ancel> 1
Applying solution 1

......

8.1.x86_64[Games_Turn-Based] (wesnoth-data == 1.3.9)

Solution 1: do not install wesnoth-data-full
do not install wesnoth-data-full-1.2.7-3.1.noarch[Games_Turn-Based]
Solution 2: do not install wesnoth-data
do not install wesnoth-data-1.3.9-12.1.noarch[Games_Turn-Based]
Solution 3: Ignore this conflict of wesnoth-data-full
number, (r)etry or (c)ancel> 1
Applying solution 1
2 Problems:
Problem: libgda-3_0 cannot be installed due to missing dependencies
Problem: libgda-sqlite cannot be installed due to missing dependencies

Problem: libgda-3_0 cannot be installed due to missing dependencies
There are no installable providers of libgda-3.0.so.3 for
libgda-3_0-3.1.1-13.
....

Solution 1: do not install libgda-3_0
do not install
libgda-3_0-3.1.1-13.1.i586[http://download.opensuse.org/reposit
ories/GNOME:/STABLE/openSUSE_10.3/]
Solution 2: Ignore this requirement just here
number, (r)etry or (c)ancel> 1
Applying solution 1

Problem: libgda-sqlite cannot be installed due to missing dependencies

....

Solution 1: do not install libgda-sqlite
do not install
libgda-sqlite-1.3.91-145.i586[http://download.opensuse.org/repositories/openSUSE:10.3/standard/]
Solution 2: Ignore this requirement just here
number, (r)etry or (c)ancel> 1
Applying solution 1

.....

Solution 1: do not install libgda-sqlite
do not install
libgda-sqlite-1.3.91-144.x86_64[http://download.opensuse.org/repositories/openSUSE:10.3/standard/]
Solution 2: Ignore this requirement just here
number, (r)etry or
(c)ancel>

Applying solution 1

....

Problem: Marking resolvable
gimp24-2.4.0-0.pm.2.x86_64[http://ftp.skynet.be/pub/packman/suse/10.3/]
as uninstallable
Solution 1: do not install gimp24
do not install
gimp24-2.4.0-0.pm.2.x86_64[http://ftp.skynet.be/pub/packman/suse/10.3/]
number, (r)etry or (c)ancel> 1
Applying solution 1

.......

Problem: Marking resolvable
gimp24-2.4.0-0.pm.2.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] as
uninstallable
Solution 1: do not install gimp24
do not install
gimp24-2.4.0-0.pm.2.i586[http://ftp.skynet.be/pub/packman/suse/10.3/]
number, (r)etry or (c)ancel> 1
Applying solution 1

.......

Problem: libtunepimp5-mp4 cannot be installed due to missing
dependencies
Solution 1: Install libofa although it would change the architecture

libofa-0.9.3-60.i586[http://download.opensuse.org/repositories/openSUSE:10.3/standard/]
provides this dependency, but would change the architecture of the installed
item
Solution 2: do not install libtunepimp5-mp4
do not install
libtunepimp5-mp4-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/]
Solution 3: Ignore this requirement just here
number, (r)etry or (c)ancel> 1
Applying solution 1

..........

Problem: libtunepimp5-mp4 cannot be installed due to missing
dependencies

Solution 1: do not install libtunepimp5
do not install
libtunepimp5-0.5.3-100.pm.7.x86_64[http://ftp.skynet.be/pub/packman/suse/10.3/]
Solution 2: Ignore this requirement just here
Solution 3: Generally ignore this requirement
number, (r)etry or (c)ancel>
Applying solution 1

Problem: libofa cannot be installed due to missing dependencies
There are no installable providers of libfftw3.so.3 for
libofa-0.9.3-60.i586[http://download.opensuse.org/repositories/openSUSE:10.3/standard/]
===
libofa-0.9.3-60.i586[http://download.opensuse.org/repositories/openSUSE:10.3/standard/]
===

libofa-0.9.3-60.i586[http://download.opensuse.org/repositories/openSUSE:10.3/standard/]
is needed by
libtunepimp5-mp4-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/]
(libofa.so.0)

fftw3-3.1.2-142.pm.3.i586[http://ftp.skynet.be/pub/packman/suse/10.3/]
provides libfftw3.so.3, but another version of that package is already
installed.

Solution 1: do not install libofa
do not install
libofa-0.9.3-60.i586[http://download.opensuse.org/repositories/openSUSE:10.3/standard/]
Solution 2: Ignore this requirement just here
number, (r)etry or (c)ancel>


etc.
etc.
etc.


--
To unsubscribe, e-mail: zypp-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: zypp-devel+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups