Mailinglist Archive: zypp-devel (115 mails)

< Previous Next >
[zypp-devel] Re: [zypp-commit] r6229 - /trunk/zypper/zypper.spec.cmake
  • From: Jan Kupec <jkupec@xxxxxxx>
  • Date: Fri, 27 Jul 2007 09:44:14 +0200
  • Message-id: <46A9A24E.1090906@xxxxxxx>
Klaus Kaempf wrote:
> * jkupec@xxxxxxxxxxxxxxxx <jkupec@xxxxxxxxxxxxxxxx> [Jul 26. 2007 15:41]:
> > Author: jkupec
> > Date: Thu Jul 26 15:41:02 2007
> > New Revision: 6229
> >
> > URL: http://svn.opensuse.org/viewcvs/zypp?rev=6229&view=rev
> > Log:
> > - cmake added to build dependencies
> > - added versions to build deps
>
> Why ?

IMO the deps should be versioned, the issue is i have just set it almost
all to the current ones. It would be good to determine the minimum
version of each build dependency with which zypper builds and use those
instead. But that would take time. I have chosen to wait for reports of
incorrectly set versions as they become needed. What do you think?

But to make it a little bit better, i can set the required versions to
those found on 10.2...

> >
> > Modified:
> >     trunk/zypper/zypper.spec.cmake
> >
> > Modified: trunk/zypper/zypper.spec.cmake
> > URL:
http://svn.opensuse.org/viewcvs/zypp/trunk/zypper/zypper.spec.cmake?rev=6229&r1=6228&r2=6229&view=diff
> >
==============================================================================
> > --- trunk/zypper/zypper.spec.cmake (original)
> > +++ trunk/zypper/zypper.spec.cmake Thu Jul 26 15:41:02 2007
> > @@ -11,9 +11,8 @@
> >  # norootforbuild
> >
> >  Name:           @PACKAGE@
> > -BuildRequires:  libzypp-devel >= 3.11.9
> > -BuildRequires:  gcc-c++ pkg-config boost-devel gettext-devel
> > -BuildRequires:  readline-devel
> > +BuildRequires:  libzypp-devel >= 3.11.9 boost-devel >= 1.33.1
gettext-devel >= 0.16 readline-devel >= 5.2
> > +BuildRequires:  gcc-c++ >= 4.2 cmake >= 2.4.6 pkg-config >= 0.21
>
> This means that one cannot compile zypper on openSUSE 10.2 any more :-(

At least cmake and libzypp is required with those versions. The others
may be lower, but we need to determine them.

jano
-- 
To unsubscribe, e-mail: zypp-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: zypp-devel+help@xxxxxxxxxxxx

< Previous Next >
This Thread
References