Mailinglist Archive: yast-commit (202 mails)

< Previous Next >
[yast-commit] Build failed in Hudson: webyast-service-head-i586 #927
See <http://yast.suse.de:3334/job/webyast-service-head-i586/927/changes>

Changes:

[Josef Reidinger] fix deploy_local for service plugin

------------------------------------------
Started by an SCM change
Checkout
[workspace] $ git fetch
Checking out origin/master
[workspace] $ git checkout -f origin/master
Previous HEAD position was 3409da1... fix deploy_local for administrator plugin
HEAD is now at 263cc18... fix deploy_local for service plugin
[workspace] $ git rev-parse origin/master
[workspace] $ git log --numstat -M --summary --pretty=raw
3409da1ffcd50026b7da7caa1eb2413392f552a9..263cc18a3588e9d5d5e85dab632ef9d4f179e365
[locks-and-latches] Checking to see if we really have the locks
[locks-and-latches] Have all the locks, build can start
[workspace] $ /bin/sh -xe /tmp/hudson7171076353438379601.sh
+ sudo -E /data/hudson/bin/build-chroot.sh webyast rest-service head-i586
SCRIPT ID: I am /data/hudson/bin/build-chroot.sh at
<http://yast.suse.de:3334/job/webyast-service-head-i586/ws/>
..copying source code
<http://yast.suse.de:3334/job/webyast-service-head-i586/ws/*>
/data/hudson/HUDSON-CHROOT/webyast-head-i586/src/rest-service
..copying make script to /data/hudson/HUDSON-CHROOT/webyast-head-i586/root
... mounting sys
... mounting proc
... mounting pts
... switching to chroot and starting build
SCRIPT ID: I am /root/make-zypp.sh at /

??,????????'????????,????,????????'????????,????,????????'????????,????,????????'????????,????,????????'????????,??

+ echo webyast-rest-service
webyast-rest-service
+ case "${MODULE}" in
+ SUBDIR=webservice
+ cd /src/rest-service
+ echo /src/rest-service
/src/rest-service
+ ls
INSTALL
Makefile
README
Rakefile
doc
index.html.template
plugins
policy-tools
rpam
webservice
webservice-tasks
+ [[ rest-service == \r\e\s\t\-\s\e\r\v\i\c\e ]]
+ echo 'start dbus..'
start dbus..
+ /etc/init.d/dbus start
Removing stale PID file /var/run/dbus/pid.
Starting D-Bus daemon..done
+ echo 'Running as root'
Running as root
+ case "${MODULE}" in
+ echo 'Creating shared tasks gem'
Creating shared tasks gem
+ pushd webservice-tasks
/src/rest-service/webservice-tasks /src/rest-service
+ rake package-local
gem build webyast-rake-tasks.gemspec
(in /src/rest-service/webservice-tasks)
Updating webyast-rake-tasks.gemspec (0.1.7)...
Updating package/rubygem-webyast-rake-tasks.spec (0.1.7)...
WARNING: no description specified
WARNING: no rubyforge_project specified
Successfully built RubyGem
Name: webyast-rake-tasks
Version: 0.1.7
File: webyast-rake-tasks-0.1.7.gem
cp webyast-rake-tasks-0.1.7.gem package
+ echo 'Installing gem...'
Installing gem...
+ gem install webyast-rake-tasks-0.1.7.gem
ERROR: http://rubygems.org/ does not appear to be a repository
Successfully installed webyast-rake-tasks-0.1.7
1 gem installed
Installing ri documentation for webyast-rake-tasks-0.1.7...
Installing RDoc documentation for webyast-rake-tasks-0.1.7...
+ popd
/src/rest-service
+ sudo rake install_policies
(in /src/rest-service)
Missing the Rails gem. Please `gem install -v= rails`, update your
RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do
have installed, or comment out RAILS_GEM_VERSION to use the latest version
installed.
(in /src/rest-service/webservice)
rake aborted!
Error on execute '/usr/bin/rake install_policies' inside webservice/
/src/rest-service/Rakefile:41
(See full trace by running task with --trace)
+ echo 'failed to install policies'
failed to install policies
+ echo 1
1
+ check_exit 0
+ '[' -z 0 ']'
+ MYEXIT=0
+ '[' 0 == 0 ']'
+ echo 'exit code: 0 ... good, lets continue'
exit code: 0 ... good, lets continue
+ return
+ cat
+ check_exit 0
+ '[' -z 0 ']'
+ MYEXIT=0
+ '[' 0 == 0 ']'
+ echo 'exit code: 0 ... good, lets continue'
exit code: 0 ... good, lets continue
+ return
+ pushd webservice
/src/rest-service/webservice /src/rest-service
+ ruby package/grantwebyastrights --user root --action grant
+ check_exit 0
+ '[' -z 0 ']'
+ MYEXIT=0
+ '[' 0 == 0 ']'
+ echo 'exit code: 0 ... good, lets continue'
exit code: 0 ... good, lets continue
+ return
+ SYSTEM_CHECK_NON_STRICT=1
+ rake system_check
Missing the Rails gem. Please `gem install -v= rails`, update your
RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do
have installed, or comment out RAILS_GEM_VERSION to use the latest version
installed.
(in /src/rest-service/webservice)
++ error_exit 1
++ echo 'ERROR: detected exit code 1'
ERROR: detected exit code 1
++ footer_and_exit 1
++ '[' -z 1 ']'
++ MYEXIT=1
++ '[' 1 == 0 ']'
++ ascii_failed
++ cat

( )
( ) (
) _ )
( \_
_(_\ \)__
(____\___))

build failed

++ echo 'stopping dbus..'
stopping dbus..
++ /etc/init.d/dbus stop
Shutting down D-Bus daemon..done
++ exit 1
... unmounting sys
... unmounting proc
... unmounting pts
[locks-and-latches] Releasing all the locks
[locks-and-latches] All the locks released
Archiving artifacts
Build wasn't successful, skipping saikuro coverage report
Publishing rails stats report...
[workspace] $ rake --silent stats
Failed to send e-mail to Martin Vidner because no e-mail address is known, and
no default e-mail domain is configured

--
To unsubscribe, e-mail: yast-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-commit+help@xxxxxxxxxxxx

< Previous Next >
List Navigation