Mailinglist Archive: yast-commit (213 mails)

< Previous Next >
[yast-commit] Build failed in Hudson: webyast-service-head-i586 #859
See <http://yast.suse.de:3334/job/webyast-service-head-i586/859/changes>

Changes:

[Jiri Suchomel] - enable reading only selected user attributes (bnc#602257)

------------------------------------------
[...truncated 4618 lines...]
2 tests, 4 assertions, 0 failures, 0 errors, 0 pendings, 0 omissions, 0
notifications
/usr/bin/ruby -I"lib:test"
"/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader.rb"
Loaded suite /usr/bin/rake
Started


Finished in 7.3e-05 seconds.

0 tests, 0 assertions, 0 failures, 0 errors, 0 pendings, 0 omissions, 0
notifications
+ exit 0
Processing files: webyast-roles-ws-0.1.0-0.noarch
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.NU8TUC
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd www
+
DOCDIR=/usr/src/packages/BUILDROOT/webyast-roles-ws-0.1.0-0.i386/usr/share/doc/packages/webyast-roles-ws
+ export DOCDIR
+ rm -rf
/usr/src/packages/BUILDROOT/webyast-roles-ws-0.1.0-0.i386/usr/share/doc/packages/webyast-roles-ws
+ /bin/mkdir -p
/usr/src/packages/BUILDROOT/webyast-roles-ws-0.1.0-0.i386/usr/share/doc/packages/webyast-roles-ws
+ cp -pr COPYING
/usr/src/packages/BUILDROOT/webyast-roles-ws-0.1.0-0.i386/usr/share/doc/packages/webyast-roles-ws
+ exit 0
Finding Provides: /usr/lib/rpm/find-provides webyast-roles-ws
Finding Requires: /usr/lib/rpm/find-requires webyast-roles-ws
Finding Supplements: /usr/lib/rpm/find-supplements webyast-roles-ws
Provides: WebYaST(org.opensuse.yast.roles)
Requires(interp): /bin/sh
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
Requires(pre): yast2-webservice
Requires(post): /bin/sh
Requires(preun): yast2-webservice
Processing files: webyast-roles-ws-testsuite-0.1.0-0.noarch
Finding Provides: /usr/lib/rpm/find-provides webyast-roles-ws
Finding Requires: /usr/lib/rpm/find-requires webyast-roles-ws
Finding Supplements: /usr/lib/rpm/find-supplements webyast-roles-ws
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files
/usr/src/packages/BUILDROOT/webyast-roles-ws-0.1.0-0.i386
Wrote:
/artifacts/webyast/rest-service/rpms/noarch/webyast-roles-ws-0.1.0-0.noarch.rpm
Wrote:
/artifacts/webyast/rest-service/rpms/noarch/webyast-roles-ws-testsuite-0.1.0-0.noarch.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.RugCL9
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd www
+ rm -rf /usr/src/packages/BUILDROOT/webyast-roles-ws-0.1.0-0.i386
+ exit 0
+ check_exit 0
+ '[' -z 0 ']'
+ MYEXIT=0
+ '[' 0 == 0 ']'
+ echo 'exit code: 0 ... good, lets continue'
exit code: 0 ... good, lets continue
+ return
+ popd
/src/rest-service
+ for rpmdir in '${SUBDIR}/package' '`find ./plugins -name package | grep -v
"rpam\|ruby-polkit"`'
++ dirname ./plugins/users/package
+ pkgdir=./plugins/users
++ basename ./plugins/users
+ pkgname=users
+ destination=/artifacts/webyast/rest-service/package/yast2-webservice-users
+ mkdir -p /artifacts/webyast/rest-service/package/yast2-webservice-users
+ rm -rf '/artifacts/webyast/rest-service/package/yast2-webservice-users/*'
+ rm -rf ./plugins/users/package/www
+ cp -r ./plugins/users/package/org.opensuse.yast.modules.yapi.users.policy
./plugins/users/package/webyast-users-ws.changes
./plugins/users/package/webyast-users-ws.spec
./plugins/users/package/www.tar.bz2
/artifacts/webyast/rest-service/package/yast2-webservice-users
+ pushd ./plugins/users/package
/src/rest-service/plugins/users/package /src/rest-service
+ case "${pkgdir}" in
+ build_spec
+ rpm --rebuilddb
+ mkdir -p /tmp
+ mkdir -p /artifacts/webyast/rest-service/rpms
+ mkdir -p /usr/src/packages/BUILD
+ mkdir -p /tmp/buildroot
+ cat
+ check_exit 0
+ '[' -z 0 ']'
+ MYEXIT=0
+ '[' 0 == 0 ']'
+ echo 'exit code: 0 ... good, lets continue'
exit code: 0 ... good, lets continue
+ return
+ /usr/bin/rpmbuild -bb --define 'run_testsuite 1' webyast-users-ws.spec
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.5nD90f
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd /usr/src/packages/BUILD
+ rm -rf www
+ /usr/bin/bzip2 -dc /src/rest-service/plugins/users/package/www.tar.bz2
+ /bin/tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd www
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.GRVYGn
+ umask 022
+ cd /usr/src/packages/BUILD
+ /bin/rm -rf /usr/src/packages/BUILDROOT/webyast-users-ws-0.1.12-0.i386
++ dirname /usr/src/packages/BUILDROOT/webyast-users-ws-0.1.12-0.i386
+ /bin/mkdir -p /usr/src/packages/BUILDROOT
+ /bin/mkdir /usr/src/packages/BUILDROOT/webyast-users-ws-0.1.12-0.i386
+ cd www
+ rm -rf doc
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.d3xwQy
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd www
+ mkdir -p
/usr/src/packages/BUILDROOT/webyast-users-ws-0.1.12-0.i386/srv/www/yastws/vendor/plugins/users
+ cp -a COPYING README Rakefile app config init.rb install.rb tasks test
uninstall.rb
/usr/src/packages/BUILDROOT/webyast-users-ws-0.1.12-0.i386/srv/www/yastws/vendor/plugins/users/
+ rm -f
/usr/src/packages/BUILDROOT/webyast-users-ws-0.1.12-0.i386/srv/www/yastws/vendor/plugins/users/COPYING
+ mkdir -p
/usr/src/packages/BUILDROOT/webyast-users-ws-0.1.12-0.i386/usr/share/PolicyKit/policy
+ install -m 0644
/src/rest-service/plugins/users/package/org.opensuse.yast.modules.yapi.users.policy

/usr/src/packages/BUILDROOT/webyast-users-ws-0.1.12-0.i386/usr/share/PolicyKit/policy/
+ RPM_BUILD_ROOT=/usr/src/packages/BUILDROOT/webyast-users-ws-0.1.12-0.i386
+ export RPM_BUILD_ROOT
+ test -x /usr/sbin/Check -a 0 = 0 -o -x /usr/sbin/Check -a '!' -z
/usr/src/packages/BUILDROOT/webyast-users-ws-0.1.12-0.i386
+ echo 'I call /usr/sbin/Check...'
I call /usr/sbin/Check...
+ /usr/sbin/Check
+ /usr/lib/rpm/brp-compress
+ /usr/lib/rpm/brp-strip-debug
+ /usr/lib/rpm/brp-check-la
+ /usr/lib/rpm/brp-symlink
+ /usr/lib/rpm/brp-desktop
WARNING: '/usr/lib/rpm/brp-desktop.data/suse-screensavers.menu' does not exist
WARNING: '/usr/lib/rpm/brp-desktop.data/preferences-gnome.menu' does not exist
WARNING: '/usr/lib/rpm/brp-desktop.data/applications-kmenuedit.menu' does not
exist
+ /usr/lib/rpm/brp-rpath
+ /usr/lib/rpm/brp-pie
+ /usr/lib/rpm/brp-rootfs
+ /usr/lib/rpm/brp-tcl
+ /usr/lib/rpm/brp-check-python
+ /usr/lib/rpm/brp-check-bytecode-version
+ /usr/lib/rpm/brp-boot-scripts
+ /usr/lib/rpm/brp-hook
Executing(%check): /bin/sh -e /var/tmp/rpm-tmp.V9EByN
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd www
+ export RAILS_PARENT=/srv/www/yastws
+ RAILS_PARENT=/srv/www/yastws
+ export TEST_DB_PATH=/tmp/webyast_test.sqlite3
+ TEST_DB_PATH=/tmp/webyast_test.sqlite3
+ rm -rf /tmp/webyast_test.sqlite3
+ RAILS_ENV=test
+ rake db:create
(in /usr/src/packages/BUILD/www)
Using DB file for tests: /tmp/webyast_test.sqlite3
+ RAILS_ENV=test
+ rake db:schema:load
*** WARNING:
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/gem_dependency.rb:119:Warning:
Gem::Dependency#version_requirements is deprecated and will be removed on or
after August 2010. Use #requirement

*** registering plugins ***
(in /usr/src/packages/BUILD/www)
Using DB file for tests: /tmp/webyast_test.sqlite3
-- create_table("accounts", {:force=>true})
-> 1.4645s
-- initialize_schema_migrations_table()
-> 0.5381s
-- assume_migrated_upto_version(20090423142313)
-> 0.1417s
Loaded suite /usr/bin/rake
Started


Finished in 0.000132 seconds.

0 tests, 0 assertions, 0 failures, 0 errors, 0 pendings, 0 omissions, 0
notifications
+ RAILS_ENV=test
+ ADD_BUILD_PATH=1
+ rake test
*** WARNING:
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/gem_dependency.rb:119:Warning:
Gem::Dependency#version_requirements is deprecated and will be removed on or
after August 2010. Use #requirement

*** registering plugins ***
/usr/bin/ruby -I"lib:test"
"/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader.rb"
"test/unit/group_test.rb" "test/unit/user_test.rb"
(in /usr/src/packages/BUILD/www)
Using DB file for tests: /tmp/webyast_test.sqlite3
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/gem_dependency.rb:119:Warning:
Gem::Dependency#version_requirements is deprecated and will be removed on or
after August 2010. Use #requirement

*** registering plugins ***
./test/unit/user_test.rb:55: warning: don't put space before argument
parentheses
Loaded suite /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader
Started
...E

Finished in 0.271852 seconds.

1) Error:
test_user_uid(UserTest):
ArgumentError: wrong number of arguments (1 for 0)
/test/unit/user_test.rb:55:in `find_all'
/test/unit/user_test.rb:55:in `test_user_uid'
mocha (0.9.8)
lib/mocha/integration/test_unit/gem_version_201_and_above.rb:20:in `run'

4 tests, 20 assertions, 0 failures, 1 errors, 0 pendings, 0 omissions, 0
notifications
/usr/bin/ruby -I"lib:test"
"/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader.rb"
"test/functional/groups_controller_test.rb"
"test/functional/users_controller_test.rb"
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/gem_dependency.rb:119:Warning:
Gem::Dependency#version_requirements is deprecated and will be removed on or
after August 2010. Use #requirement

*** registering plugins ***
/usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:31: command not found:
Loaded suite /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader
Started
.......

Finished in 0.474996 seconds.

7 tests, 11 assertions, 0 failures, 0 errors, 0 pendings, 0 omissions, 0
notifications
/usr/bin/ruby -I"lib:test"
"/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader.rb"
Errors running test:units!
error: Bad exit status from /var/tmp/rpm-tmp.V9EByN (%check)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.V9EByN (%check)
+ check_exit 1
+ '[' -z 1 ']'
+ MYEXIT=1
+ '[' 1 == 0 ']'
+ footer_and_exit 1
+ '[' -z 1 ']'
+ MYEXIT=1
+ '[' 1 == 0 ']'
+ ascii_failed
+ cat

( )
( ) (
) _ )
( \_
_(_\ \)__
(____\___))

build failed

+ echo 'stopping dbus..'
stopping dbus..
+ /etc/init.d/dbus stop
/etc/rc.status: line 42: /dev/ttyS0: No such file or directory
Shutting down D-Bus daemon..done
+ exit 1
... unmounting sys
... unmounting proc
... unmounting pts
[locks-and-latches] Releasing all the locks
[locks-and-latches] All the locks released
Archiving artifacts
Build wasn't successful, skipping saikuro coverage report
Publishing rails stats report...
[workspace] $ rake --silent stats
Failed to send e-mail to Jiri Suchomel because no e-mail address is known, and
no default e-mail domain is configured

--
To unsubscribe, e-mail: yast-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-commit+help@xxxxxxxxxxxx

< Previous Next >