Mailinglist Archive: radeonhd (408 mails)

< Previous Next >
Re: [radeonhd] xbacklight does not works again ?
  • From: Egbert Eich <eich@xxxxxxx>
  • Date: Mon, 29 Jun 2009 19:09:53 +0200
  • Message-id: <19016.62817.489024.329081@xxxxxxxxxxxxxx>
Rafa? Mi?ecki writes:
2009/6/24 Matthias Hopf <mhopf@xxxxxxx>:
Do you know a version where it worked? Possibly to git-bisect this?
git commits efa0b5475517 and 742a4b4e are likely candidates for breaking
anything regarding properties.

That is probably still the best thing you can do. Maybe compiling with
-DDEBUG before and producing a -logverbose 7 log file. But I'm unsure
whether this will include the necessary information.

Starting from efa0b5475517 I don't see _Backlight anymore for my PANEL.

The (really) weird thing is this was working for you Vladimir earlier.
In my case there was _Backlight property with completly wrong value,
and every try of changing it crashed driver. So you saw _Backlight
property because of bug and setting this property... shouldn't work
for you actually ;)

Possibly it's due to the fact that BlLevel is -1 in this case - a fact
which was accidentally ignored before efa0b5475517.

Real code for backlight controll is available, it's just disabled for
some reason. Grep rhd_lvtma.c for "backlight" - it's inside #ifdef
NOT_YET. I enabled this property locally and it was working fine. But

No, this code is different. It's for AtomBIOS. A lot of data structures
are missing which have not been set up if the hard coded path is taken.

I didn't care much about checking that as I'll try to implement
backlight in KMS (proper place for this).

Can someone explaing me why we have two functions LVDSSetBacklight? In:
rhd_dig.c
rhd_lvtma.c

See my previous email and the comment above.

Cheers,
Egbert.
--
To unsubscribe, e-mail: radeonhd+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: radeonhd+help@xxxxxxxxxxxx

< Previous Next >