Mailinglist Archive: radeonhd (300 mails)

< Previous Next >
Re: [radeonhd] 0x95C5:0x174B:0xE670: Sapphire Radeon HD 3450
  • From: Brad du Plessis <bradd@xxxxxxxxx>
  • Date: Thu, 15 May 2008 12:07:02 +0200
  • Message-id: <482C0B46.4010002@xxxxxxxxx>
Egbert Eich wrote:
Matthias Hopf writes:
> On May 14, 08 18:59:07 +0200, Egbert Eich wrote:
> > Found it!
> > > > This card is using uniphyB which wasn't detected correctly.
> > The BIOS helped to locate the problem.
> > Great work, Egbert!
> > Just for the record: What is uniphyB? Could this be the source of some
> of the other (few) connection table breakages we saw lately?

uniphyB is one of the transmitters introduced with DCE3.0. It is capable of
doing TMDS (DVI + HDMI), DP.
If you see the breakages on RV620 or RV635 then it could well be this problem.

I registered on this list yesterday to try and solve this very problem with the Sapphire HD3450. I took it upon myself to create a quirk for this card in rhd_id.c. I found that UNIPHYB was the output that was supposed to be used for DVI on connector 1. When I set it up to use UNIPHYB X would start up, but I'd get no output (monitor indicated lost signal).

This is the quirk I added:

#define DVI_HD3450 \
{ { RHD_CONNECTOR_TV, "7PIN_DIN TV1 CV", RHD_DDC_1, RHD_HPD_NONE, \
{ RHD_OUTPUT_DACB, RHD_OUTPUT_NONE }}, \
{ RHD_CONNECTOR_DVI, "DUAL_LINK_DVI_I CRT1 DFP1", RHD_DDC_0, RHD_HPD_1, \
{ RHD_OUTPUT_UNIPHYB, RHD_OUTPUT_DACA }}, \
{ RHD_CONNECTOR_DVI, "DUAL_LINK_DVI_I CRT2 DFP2", RHD_DDC_1, RHD_HPD_0, \
{ RHD_OUTPUT_KLDSKP_LVTMA, RHD_OUTPUT_DACB }}}

and for the device:
{ 0x95C5, 0x174B, 0xE670, "Sapphire HD 3450", RHD_CARD_FLAG_NONE, DVI_HD3450 },

I experimented a bit by using UNIPHYA instead of UNIPHYB and then I'd actually get video in X, but it looked really strange and distorted.

Would you expect that a quirk like the one above would fix this?

Thanks,
Brad



--
To unsubscribe, e-mail: radeonhd+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: radeonhd+help@xxxxxxxxxxxx

< Previous Next >