Mailinglist Archive: radeonhd (311 mails)

< Previous Next >
[radeonhd] [Bug 14219] screen goes blank permanently after swiching to console
  • From: bugzilla-daemon@xxxxxxxxxxxxxxx
  • Date: Tue, 5 Feb 2008 04:29:58 -0800 (PST)
  • Message-id: <20080205122959.0A3AD130053@xxxxxxxxxxxxxxxxxxxxxxxx>
http://bugs.freedesktop.org/show_bug.cgi?id=14219





--- Comment #3 from Luc Verhaegen <lverhaegen@xxxxxxx> 2008-02-05 04:29:58 PST
---
It does make sense there though, as FBOffset is the offset from whatever
framebuffer base there is (either it can be the card internal framebuffer base
or the CPU known framebuffer offset).

So FBOffset should always be between 0 and pScrn->videoRam*1024...

*eurocent drops*

*checks*

Bugger. *1024 is missing Caught out by this... Again...

So what we were doing before was checking whether the VGA offset into the
framebuffer is smaller 256kB... urgh.

Pushing up a fix right away, not that this will fix the issue you are seeing,
but at least the check will be correct.

btw i cannot reproduce locally with any 512MB card.


--
Configure bugmail: http://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
_______________________________________________
xorg-team mailing list
xorg-team@xxxxxxxxxxx
http://lists.x.org/mailman/listinfo/xorg-team
--
To unsubscribe, e-mail: radeonhd+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: radeonhd+help@xxxxxxxxxxxx

< Previous Next >