Mailinglist Archive: packet-writing (32 mails)

< Previous Next >
compilation error with kernel 2.4.20.SuSE
Hi!

I get a compilation error ehen trying to compile the patched kernel on
SuSE. I use the kernel 2.4.20.SuSE.

The problem is that the SuSE patches change blk_started_io() (defined
in include/linux/blkdev.h) from having one argument to two, and
pktcdvd.c uses this funktion. The change is introduced by SuSEs
elevator_lowlatency patch. Unfortunately, blk_started_io() is only
udes in that patch and pktcdvd.c and I have no idea what it is good
for, so I don't dare to mangle the code myself. Any ideas what to do
to make it compile?

Thanks in advance,
Joe.

< Previous Next >
Follow Ups