Mailinglist Archive: opensuse (1480 mails)

< Previous Next >
Re: [opensuse] Amazon Not Available on openSUSE 12.1
  • From: C <smaug42@xxxxxxxxxxxx>
  • Date: Sat, 10 Mar 2012 13:47:02 +0100
  • Message-id: <CAOVv=gOUaw5Wy-VD9diCrfpRiVgM9TRXczWAXrTZz1-AR1k6fQ@mail.gmail.com>
On Sat, Mar 10, 2012 at 08:53, Swapnil Bhartiya
<swapnil.bhartiya@xxxxxxxxx> wrote:
Hi,

Until Google Music is available in Europe I purchase music from Amazon. In
order to download the purchased file you need Amazon downloader which is
available for openSuse 11.1 only. How to download or install Amazon
downloader on openSUSE 12.1?


It's not currently working in 12.1 - you can install the downloader
using the wiki instructions (linked below) or by following the steps
here: http://www.edv-krischer.de/wiki/linux/howto/amazon-mp3-downloader

But... when you launch the downloader you get the following error:
amazonmp3: symbol lookup error: amazonmp3: undefined symbol:
_ZN5boost6system19get_system_categoryEv

(as is documented on the howto)... I've verified the error message on
my system. This is something to do with Boost Mutex... guessing.. the
old version and the new version are not binary compatible... ie you're
out of luck on this one unless you roll back to an old version of
Boost.

You may have some success with the Banshee solution documented here:
http://en.opensuse.org/SDB:Amazon_MP3_downloader_on_openSUSE_11.2
If you're using KDE4, Amarok has an Amazon plugin that is enabled by default.

C.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
References