Mailinglist Archive: opensuse (868 mails)

< Previous Next >
Re: [opensuse] X11 forwarding on 11.4
On 5/29/2011 11:45 AM, Patrick Shanahan wrote:
* John Andersen <jsamyth@xxxxxxxxx> [05-29-11 14:09]:
On 5/28/2011 9:17 PM, Patrick Shanahan wrote:
What I failed to say was that I cannot forward X from the 192.168.1.10
(11.4) box to the 192.168.1.3 (11.2) box either

Ah, well that does throw a whole new light on it...

I found this on google: http://www.cisl.ucar.edu/docs/ssh/guide/node30.html
Which seems to suggest that there may be a problem with your ".Xauthority"
file on 11.4,
either locked or has wrong permissions or something. The age also discusses
turning on -v for diagnosing.

I don't believe there is a problem with ~/.Xauthority on 11.4, at least
there is no indication in the debug output ( -vv). That output is here:
http://wahoo.no-ip.org/~pat/ssh.sigon.txt

tks,

Ok, so the part that says:

debug2: channel 0: rcvd ext data 64
xterm Xt error: Can't open display:
xterm: DISPLAY is not set

says something is not setting your DISPLAY environmental.

If you can log in and get a text shell (not xterm)
issue the following command:

set | grep DISPLAY

And you should see something like:
DISPLAY=localhost:10.0

If not, it could still be something in the sshd_config.

--
_____________________________________
---This space for rent---
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups