Mailinglist Archive: opensuse (963 mails)

< Previous Next >
Re: [OT] [opensuse] I'm stuck - SSL Certs / email server
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Fri, 29 Apr 2011 08:53:06 +0200
  • Message-id: <ipdn8i$hh5$1@saturn.local.net>
Jim Flanagan wrote:

Still having problems receiving, or rather reading received mails via
imaps. And this is getting pretty weird. Thunderbird does not like
setting imap security to SSL/TLS (port 9930, and still gives the error
that ssl rx record is too long. Setting it to STARTTLS is worse (on
port 143), all sorts of errors fly up saying that the server is not
available or has disconnected.

I'm using plain IMAP + STARTTLS with thunderbird and dovecot, no
problems.

Apr 28 19:34:30 jimmee postfix/smtpd[6823]: connect from
localhost[::1] Apr 28 19:34:30 jimmee postfix/smtpd[6823]: setting up
TLS connection from localhost[::1]
Apr 28 19:34:30 jimmee postfix/smtpd[6823]: Anonymous TLS connection
established from localhost[::1]: TLSv1 with cipher DHE-RSA-AES256-SHA
(256/256 bits)
Apr 28 19:35:00 jimmee postfix/smtpd[6823]: warning: Illegal address
syntax from localhost[::1] in RCPT command: <jim@192.168.1.117>
Apr 28 19:35:05 jimmee postfix/smtpd[6823]: lost connection after RSET
from localhost[::1]
Apr 28 19:35:05 jimmee postfix/smtpd[6823]: disconnect from
localhost[::1]

If you really want to see what's going on here, add localhost to
debug_peer_list in your postfix config.


Accessing imaps with KMail, /var/log/mail shows:

Apr 28 19:53:25 jimmee postfix/smtpd[7419]: connect from
unknown[192.168.1.117]
Apr 28 19:53:25 jimmee postfix/smtpd[7419]: setting up TLS connection
from unknown[192.168.1.117]
Apr 28 19:53:25 jimmee postfix/smtpd[7419]: Anonymous TLS connection
established from unknown[192.168.1.117]: TLSv1 with cipher
ADH-CAMELLIA256-SHA (256/256 bits)
Apr 28 19:53:25 jimmee postfix/smtpd[7419]: 9CD174044E:
client=unknown[192.168.1.117]
Apr 28 19:53:25 jimmee postfix/cleanup[7429]: 9CD174044E:
message-id=<4DBA0C04.20702@xxxxxxxxxx>
Apr 28 19:53:25 jimmee postfix/qmgr[5634]: 9CD174044E:
from=<jim@xxxxxxxxxx>, size=1313, nrcpt=1 (queue active)
Apr 28 19:53:25 jimmee postfix/smtpd[7419]: disconnect from
unknown[192.168.1.117]
Apr 28 19:53:25 jimmee postfix/lmtp[7431]: 9CD174044E:
to=<mimi@[192.168.1.118]>,
relay=jjfiii.com[/var/lib/imap/socket/lmtp], delay=0.29,
delays=0.08/0.01/0.02/0.18, dsn=2.1.5, status=sent (250 2.1.5 Ok)
Apr 28 19:53:25 jimmee postfix/qmgr[5634]: 9CD174044E: removed

The TBird conneciton fails, the KMail one doesn't.

Thunderbird uses 'jim@192.168.1.117', which postfix doesn't like, kmail
uses 'jim@192.168.1.117'.



--
Per Jessen, Zürich (11.9°C)

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups