Mailinglist Archive: opensuse (1502 mails)

< Previous Next >
[opensuse] USB device in VirtualBox
  • From: Jay C Vollmer <jvollmer@xxxxxxxx>
  • Date: Thu, 2 Apr 2009 17:25:00 -0500
  • Message-id: <200904021725.00796.jvollmer@xxxxxxxx>
Greetings fellow listers.

I am encountering a vexing problem with the current 64-bit version of
Sun's VirtualBox(2.1.4r42893) on openSUSE 11.0. I've noticed that I
cannot mount USB devices in a Windows XP guest, even though everything
seems to be configured correctly:

USB and USBEHCI are enabled in the xVM Manager application.

usbfs entry added to /etc/fstab to allow group access to USB bus.

No USB filters are applied.

users have been added to the vboxusers group and USB drives show up
in /dev/bus/usb as belonging to that group - so the usbfs line in fstab
must be working.

When the Windows guest is started, mousing-over the USB icon indicates
that no devices are attached, but right-clicking on the icon shows the
name of the device in grayed text - so I know it knows it's there, but
it will not mount in the Windows guest.

opening a shell and typing: "VBoxManage list usbhost" indicates that the
USB device is there, but its current state is listed as: Unavailable.

Now, the problem: What can I do to make the device available, as I
assume that doing so will allow it to mount in the Windows guest?

aTdHvAaNnKcSe

--
JAY VOLLMER
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >