Mailinglist Archive: opensuse (2740 mails)

< Previous Next >
Re: [opensuse] Sometimes, I'm denied access to my scanner as user.
  • From: Patrick Shanahan <paka@xxxxxxxxxxxx>
  • Date: Mon, 1 Dec 2008 18:27:46 -0500
  • Message-id: <20081201232746.GJ11313@xxxxxxxxxxxxxxx>
* Carlos E. R. <carlos.e.r@xxxxxxxxxxxx> [12-01-08 18:03]:

I can normally use my scanner as user, but today, after pluggin it in, I
can't. Xsane says that no device was found... but if run it as root, there
is no problem.

nimrodel:~ # lsusb
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 004: ID 04b8:0110 Seiko Epson Corp. Perfection 1650
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 039: ID 0665:5161
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

cer@nimrodel:~> l /dev/bus/usb/003/004
crw-rw-r-- 1 root lp 189, 259 2008-12-01 21:57 /dev/bus/usb/003/004


I disconnect and reconnect the scanner:

Bus 003 Device 005: ID 04b8:0110 Seiko Epson Corp. Perfection 1650

crw-rw-r-- 1 root lp 189, 260 2008-12-01 23:38 /dev/bus/usb/003/005


I don't know why it belongs to root?


18:15 wahoo:~ > lsusb
Bus 002 Device 003: ID 046d:c404 Logitech, Inc. TrackMan Wheel
Bus 002 Device 002: ID 051d:0002 American Power Conversion Back-UPS Pro
500/1000/1500
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 012: ID 05e3:0710 Genesys Logic, Inc. USB 2.0 33-in-1 Card Reader
Bus 001 Device 006: ID 046d:0870 Logitech, Inc. QuickCam Express
Bus 001 Device 005: ID 04b4:6560 Cypress Semiconductor Corp. CY7C65640 USB-2.0
"TetraHub"
Bus 001 Device 004: ID 04b8:011b Seiko Epson Corp. Perfection 2400 Photo
Bus 001 Device 001: ID 0000:0000

18:15 wahoo:~ > l /dev/bus/usb/001/004
crw-rw-r--+ 1 root root 189, 3 2008-11-20 20:57 /dev/bus/usb/001/004



There is a program that list to what devices an user has access, but I
forget which command it is.

Perhaps...

cer@nimrodel:~> /sbin/resmgr test scanner
user does have access


18:16 wahoo:~ > /sbin/resmgr test scanner
status code 501
server message follows:
command not understood

(as user)
18:16 wahoo:~ > /sbin/resmgr list usb
rw-- /dev/bus/usb/001/006
rw-- /dev/bus/usb/001/004



... but xsane keep saying I have not access.


This has happened to me in the past, and I had to reboot. This time I'll
wait to see if we can find out why ;-)


Hal ???

--
Patrick Shanahan Plainfield, Indiana, USA HOG # US1244711
http://wahoo.no-ip.org Photo Album: http://wahoo.no-ip.org/gallery2
Registered Linux User #207535 @ http://counter.li.org
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References