Mailinglist Archive: opensuse (1986 mails)

< Previous Next >
Re: [opensuse] Heartbeat GUI
  • From: "Andrew Beekhof" <beekhof@xxxxxxxxx>
  • Date: Mon, 17 Nov 2008 10:08:34 +0100
  • Message-id: <26ef5e70811170108v4b12484ch4c34b5581f56cd75@xxxxxxxxxxxxxx>
On Sun, Nov 16, 2008 at 00:51, Laurent Léonard <laurent@xxxxxxxxxxxxxx> wrote:
Le vendredi 14 novembre 2008 à 22:02, Andrew Beekhof a écrit :
On Fri, Nov 14, 2008 at 18:31, Laurent Léonard <laurent@xxxxxxxxxxxxxx>
wrote:
Hi,

I installed Heartbeat on a fresh OpenSUSE 11.0 but I don't find the
heartbeat-gui package... I know the management project is now Pacemaker
but how can I start the GUI ?

It doesn't yet exist in the distro but I believe that is being addressed.

You can grab the latest, direct from the project, from the build
service by pointing your browser to:

http://software.opensuse.org/ymp/server:ha-clustering/openSUSE_11.0/pacemak
er-pygui.ymp

Also, be sure to check out:
http://clusterlabs.org/mw/FAQ#How_Do_I_Enable_the_GUI.3F

Thank you for your answer !

Heartbeat is installed and configured ("crm_mon" returns "online" for both
nodes). So I installed "pacemaker-gui" from the HA-clustering repository and
I added the two lines to the ha.cf file, but when I restart Heartbeat I can't
connect with the GUI...

I tried "telnet localhost 5560", but it give a "connection refused" error
message.

Mgmtd seems to segfault... I got this in /var/log/messages :
Nov 15 23:03:59 hatest1 heartbeat: [5739]: WARN:
Managed /usr/lib64/heartbeat/mgmtd -v process 5756 killed by signal 11
[SIGSEGV - Segmentation violation].
Nov 15 23:03:59 hatest1 heartbeat: [5739]: ERROR:
Managed /usr/lib64/heartbeat/mgmtd -v process 5756 dumped core
Nov 15 23:03:59 hatest1 heartbeat: [5739]: ERROR: Respawning
client "/usr/lib64/heartbeat/mgmtd -v":

And if I upgrade Heartbeat with the packages from the HA-clustering
repository, the machine reboots when I try to reboot Heartbeat ! I don't know
what's happen but it is a critical bug...

You can prevent that by specifying "crm respawn" instead of "crm yes"
The project leader decided to change the semantics of "crm yes" to
panic the node if any child process terminated :-(

Any idea to get pacemaker-gui working with current stable Heartbeat from
OpenSUSE 11.0 ?

Did you install heartbeat and pacemaker from that location too?
Or just the pygui package?
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >